MikroTik-Scripts: Benachrichtigung über die Geräteverbindung zum Netzwerk

Wir richten eine Benachrichtigung ein, wenn ein neues Gerät mithilfe der DHCP-Servereinstellungen (Zuweisen einer IP-Adresse oder Ablaufen eines Leasingvertrags) mit einem lokalen Netzwerk oder WLAN verbunden wird. Wir senden eine Nachricht an Telegram oder E-Mail.

Mein WLAN-Router sagt, dass ein Mann mit meiner Frau zu Hause war, während ich bei der Arbeit war.

 LickingWoundSalt (Reddit)

Dies ist jedoch nicht die einzige Anwendung dieser Möglichkeit. 🙂

Wenn Sie die Lease-Zeit für die IP-Adresse (Lease Time) auf 10 Stunden festlegen, können Sie herausfinden, wann die Computer der Mitarbeiter mit dem Netzwerk verbunden waren oder wer den Computer beim Verlassen des Arbeitsplatzes nicht ausschaltet.

Wenn Sie ein einfaches WLAN-Passwort verwenden, stellen Sie möglicherweise fest, dass das Kind des Nachbarn auch Ihr WLAN verwendet. 🙂

Das Skript hilft Ihnen dabei, die vorhandenen Probleme mit der Stabilität der Verbindung oder Netzwerkprobleme herauszufinden.

Sie können auch andere Aktionen konfigurieren, wenn Sie dieses Skript aktivieren.

Artikel in anderen Sprachen:
🇺🇸 – MikroTik Scripts: Notification of device connection to the network
🇪🇸 – MikroTik Scripts: Notificación de la conexión del dispositivo a la red
🇷🇺 – MikroTik Скрипты: Уведомление о подключении устройства к сети
🇫🇷 – Scripts MikroTik: notification de la connexion de l’appareil au réseau
🇳🇱 – MikroTik-scripts: Melding van apparaat verbinding met het netwerk

Skript: Senden einer Benachrichtigung, wenn ein Gerät mit dem Netzwerk verbunden ist

Das Mikrotik Script wird ausgelöst, wenn einem neuen Gerät oder einem Gerät, dessen IP-Adresse abgelaufen ist, eine IP-Adresse zugewiesen wird. Sendet eine Telegramnachricht oder eine E-Mail.

Die Nachricht enthält:

  1. Gerätename (Computername oder vom Hersteller vergeben);
  2. Kommentar (wenn dem Gerät eine statische Adresse mit dem angegebenen Kommentar zugewiesen wurde);
  3. Name der DHCP-Schnittstelle;
  4. IP- und MAC-Adresse des angeschlossenen Geräts.

🔔 Ich empfehle, in den Kommentaren zu den Geräten nur englische Zeichen zu verwenden!

Das Skript verwendet Funktionsaufrufe:
MikroTik-Skripte: Senden einer Nachricht an Telegram (funktion);
MikroTik-Skripte: Senden von benachrichtigungen und daten an E-mails (funktion).

Beispiel-E-Mail vom DHCP-Server - Neues Gerät verbunden
Beispiel-E-Mail vom DHCP-Server – Neues Gerät verbunden

Ändern Sie die Lease-Zeit für die IP-Adresse

Stellen Sie die Lease-Zeit für die IP-Adresse auf 10 Stunden ein.

[IP] -> [DHCP Server] -> [Your DHCP server] -> [General: Lease Time=10:00:00]

Benachrichtigungs Skript erstellen

[IP] -> [DHCP Server] -> [Script]

Script code

:if ($leaseBound =1) do={
    # Variables
    :local Time [/system clock get time];
    :local Date [/system clock get date];
    :local Comment [/ip dhcp-server lease get value-name=comment number=[/ip dhcp-server lease find address=$leaseActIP]]
    :local DeviceName [/system identity get name];

    # START Send Telegram Module
    :local MessageText "\F0\9F\9F\A2 <b>$DeviceName: New DHCP client</b> %0D%0A <b>Name:</b> $"lease-hostname" %0D%0A <b>Comment:</b> [$Comment] %0D%0A <b>Interface:</b> $leaseServerName %0D%0A <b>IP:</b> $leaseActIP %0D%0A <b>MAC:</b> $leaseActMAC";
    :local SendTelegramMessage [:parse [/system script  get MyTGBotSendMessage source]]; 
    $SendTelegramMessage MessageText=$MessageText;
    #END Send Telegram Module

    # START Send Email Module
    :local SendTo "notify@mhelp.pro";
    :local Subject "\F0\9F\9F\A2 INFO: $DeviceName [$Date $Time] New DHCP client";
    :local MessageText "Name: $"lease-hostname", Comment: $Comment, Interface: $leaseServerName IP: $leaseActIP MAC: $leaseActMAC";
    :local FileName "";
    :local SendEmail [:parse [/system script get SendEmailFunction source]];
    $SendEmail SendTo=$SendTo TextMail=$MessageText Subject=$Subject FileName=$FileName;
    # END Send Email Module
}
MikroTik-Scripts: Benachrichtigung über die Geräteverbindung zum Netzwerk

🟢 In diesem Artikel wurde erläutert, wie Sie ein MikroTik-Skript zum Senden einer Nachricht von einem DHCP-Server erstellen – das neue Gerät ist mit dem lokalen Netzwerk verbunden. Ich hoffe, Sie haben es geschafft, Benachrichtigungen per Telegram oder E-Mail zu senden. Wenn Sie jedoch Probleme haben, Informationen zu erhalten, können Sie diese gerne in die Kommentare schreiben. Ich werde versuchen zu helfen.

Das Skript wird überprüft: hAP ac lite [RouterBOARD 952Ui-5ac2nD], RouterOS 6.47.8 (stable).

P.S.Wenn Sie eine interessante oder ungewöhnliche Verwendung des Skripts haben, schreiben Sie in die Kommentare, die ich dem Artikel hinzufügen werde. 🙂

📒 Wenn Sie Materialien von der Seite kopieren, müssen Sie den Autor (Yun Sergey) und einen Hyperlink zur Quelle (MHelp.pro) angeben.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.