MikroTik-Skripte: Automatisches Upgrade der RouterBOARD-Firmware

Skript zum automatischen Aktualisieren der Firmware (Bootloader) von MikroTik nach dem Aktualisieren der RouterOS-Version, sodass die Versionen von MikroTik RouterOS und dem RouterBOARD-Bootloader übereinstimmen.

Früher musste ich die RouterBOARD-Bootloader-Version manuell aktualisieren, nach dem Aktualisieren der RouterOS-Version erforderte dies zusätzliche Zeit und Aufmerksamkeit, wenn viele MikroTik-Geräte vorhanden waren. Ich habe ein Skript geschrieben, um diesen Prozess zu automatisieren.

Andere Sprachen:

Beschreibung

Das Skript wird 2 Minuten später (180 Sekunden Verzögerung) nach dem Booten des MikroTik-Geräts ausgeführt. Verglichen werden die verwendete RouterBOARD-Firmware-Version (current-firmware) und die zum Upgrade angebotene RouterBOARD-Version (upgrade-firmware). Wenn die Versionen nicht übereinstimmen, lädt das MikroTik-Gerät die aktualisierte Version der RouterBOARD-Firmware herunter und startet das Gerät nach der Installation der neuen Firmware-Version neu.

✏️ Notiz. Stellen Sie sicher, dass Ihre Internetverbindung während der Verzögerungszeit des Skripts eine Verbindung herstellen kann, andernfalls erhöhen Sie die Verzögerung, bevor Sie das Skript ausführen.

Skript erstellen (manuell)

Dieses Skript sollte ausgeführt werden, sobald das Gerät hochfährt, daher erstellen wir das Skript im Taskplaner, nicht im Skriptspeicher.

Menü

[System] - [Scheduler] - [+]

Skriptdaten

Name: AutoUpgradeFirmware
Start Time: startup
Policy: read, policy, reboot, write.

Skript

:delay 180s;
/system/routerboard
:if ([get current-firmware] != [get upgrade-firmware]) do={
    upgrade;
    /system/reboot;
    }
Automatisches Upgrade-Skript der MikroTik RouterBOARD-Firmware

Skript erstellen (automatisch)

/system scheduler
add name=AutoUpgradeFirmware on-event=":delay 180s;\r\
    \n/system/routerboard\r\
    \n:if ([get current-firmware] != [get upgrade-firmware]) do={\r\
    \n    upgrade;\r\
    \n    /system/reboot;\r\
    \n    }" policy=reboot,read,write,policy start-time=startup

Jetzt ist die Firmware-Version des Geräts (Bootloader) immer dieselbe wie die RouterOS-Version, und ich muss keine Zeit damit verbringen, die Firmware manuell zu aktualisieren.

Getestetes Skript: RouterOS v7


🟢 Das Skript zum automatischen Aktualisieren der Firmware eines MikroTik-Geräts, wenn die installierte RouterOS-Version geändert wird, wurde in diesem Artikel besprochen. Ich hoffe, Sie können jetzt die Aufgabe des Upgrades von RouterOS und Geräte-Bootloader-Version automatisieren. Wenn Sie jedoch beim Einrichten des Skripts auf Probleme stoßen, können Sie dies gerne in den Kommentaren schreiben. Ich werde versuchen zu helfen.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert

Adblock
detector