MikroTik-Skripte: Erkennen Sie unbekannte DHCP-Server im Netzwerk

Konfigurieren der Erkennung eines unbekannten DHCP-Servers im Netzwerk und Senden einer Benachrichtigung an Telegramm oder E-Mail. Der Name der DHCP-Schnittstelle, auf der sich der Server befindet, sowie die IP- und MAC-Adressen des nicht autorisierten Geräts werden gesendet.

Konfigurieren der Erkennung eines unbekannten DHCP-Servers im Netzwerk und Senden einer Benachrichtigung an Telegramm oder E-Mail. Der Name der DHCP-Schnittstelle, auf der sich der Server befindet, sowie die IP- und MAC-Adressen des nicht autorisierten Geräts werden gesendet.

Verwenden Sie die Einstellung „Warnungen“ in den Einstellungen des DHCP-Servers, um schnell über das Auftreten eines nicht autorisierten DHCP-Servers im lokalen Netzwerk informiert zu werden.

Artikel in anderen Sprachen:
🇺🇸 – MikroTik Scripts: Discover Unknown DHCP Server on the Network
🇪🇸 – Scripts MikroTik: Descubre un servidor DHCP desconocido en red
🇷🇺 – MikroTik Скрипты: Обнаружение неизвестного DHCP сервера в сети
🇫🇷 – Scripts MikroTik: Découverte d’un serveur DHCP inconnu sur le réseau
🇳🇱 – MikroTik-scripts: Detectie van een onbekende DHCP-server op het netwerk

Alarm erstellen

Anfangsdaten:

  • Interface: bridge1-lan – Name der DHCP-Serverschnittstelle;
  • Valid Servers: 64:D1:54:52:6C:36 – MAC-Adresse der DHCP-Server Schnittstelle (bridge1-lan);
  • Alert Timeout: 10 Minuten – Intervall zum Überprüfen eines nicht autorisierten DHCP-Servers und zum Senden einer Benachrichtigung.

Warnung einrichten:

[IP] -> [DHCP Server] -> [Alerts] -> [+] -> [Interface: bridge1-lan] -> [Valid Servers: 64:D1:54:52:6C:36] -> [Alert Timeout: 00:10:00]

Ich empfehle, das Testskript im Fenster Alert aufzurufen, anstatt den Skripttext zu platzieren. Wenn sich die Skripte an einer Stelle befinden [System] -> [Scripts], wird die Benutzerfreundlichkeit des Geräts verbessert, als wenn die Skripte in bestimmten Geräteeinstellungen platziert werden.

Script call code:

/system script run DiscoverUnknownDHCPServer
Erstellen Sie eine DHCP-Server Warnung

Skript: Ermitteln Sie einen unbekannten DHCP-Server und senden Sie eine Nachricht an Telegram

Um eine Telegrammnachricht zu senden, verwende ich den Funktionsaufruf – MikroTik-Skripte: Senden einer Nachricht an Telegram (funktion).

Beispiel einer Telegram Warnmeldung
Beispiel einer Telegram Warnmeldung

Let’s create a script:

[System] -> [Scripts] -> [+] -> [Name: DiscoverUnknownDHCPServer] -> [Policy: read, write, polisy, test]

Skriptcode:

# Find DHCP Alert 
:local CurrentTime [/system clock get time];
:local MsgID [/log find where message ~"dhcp alert" time =$CurrentTime];
:local MsgText [/log get number=$MsgID message];

# Send Telegram Message
:local DeviceName [/system identity get name];
:local MessageText "\F0\9F\94\B4 <b>$DeviceName: UNKNOWN DHCP SERVER FOUND! </b> Info: $CurrentTime $MsgText";
:local SendTelegramMessage [:parse [/system script  get MyTGBotSendMessage source]];
$SendTelegramMessage MessageText=$MessageText;
MikroTik-Skripte: Erkennen Sie unbekannte DHCP-Server im Netzwerk

Skript: Ermitteln Sie einen unbekannten DHCP-Server und senden Sie eine Nachricht an eine E-Mail

Zum Senden einer Telegram Nachricht verwende ich den Funktionsaufruf – MikroTik-Skripte: Senden von benachrichtigungen und daten an E-mails (funktion)

Beispiel für eine Warn-E-Mail
Beispiel für eine Benachrichtigungs-EMail von MHelp.pro

Lassen Sie uns ein Skript erstellen:

[System] -> [Scripts] -> [+] -> [Name: DiscoverUnknownDHCPServer] -> [Policy: read, write, polisy, test]

Dieses Skript verwendet keinen Datei-Upload, daher wird dem Parameter FileName ein leerer Wert „“ zugewiesen.

Skriptcode:

# Find DHCP Alert 
:local CurrentTime [/system clock get time];
:local MsgID [/log find where message ~"dhcp alert" time =$CurrentTime];
:local MsgText [/log get number=$MsgID message];

# Send Email
:local DeviceName [/system identity get name];
:local Time [/system clock get time];
:local Date [/system clock get date];

:local SendTo "mail@mail.com";
:local Subject "\F0\9F\94\B4 CRITICAL: $DeviceName [$Date $Time] UNKNOWN DHCP SERVER FOUND!";
:local MessageText "$MsgText";
:local FileName "";

:local SendEmail [:parse [/system script get SendEmailFunction source]];
$SendEmail SendTo=$SendTo TextMail=$MessageText Subject=$Subject FileName=$FileName;
Skript: Ermitteln Sie einen unbekannten DHCP-Server und senden Sie eine Nachricht an die E-Mail

Einzeiliges Skript

Senden einer Benachrichtigung über einen unbekannten DHCP-Server in Telegram:

/tool fetch url="https://api.telegram.org/bot<BotToken>/sendMessage\?chat_id=<GroupID>&text=Unknown DHCP server on interface: $interface (IP: $address, MAC:$"mac-address")" keep-result=no;

Senden einer Benachrichtigung über einen unbekannten DHCP-Server an eine E-Mail:

/tool e-mail send to=dest_mail@mail.com server=[:resolve "smtp.mail.com"] port=465 start-tls=tls-only user="my_mail@mail.com" password="Pa$$woRD"  from="my_mail@mail.com" subject="$[/system identity get name] UNKNOWN DHCP SERVER FOUND!" body="Unknown DHCP server on interface: $interface (IP: $address, MAC:$"mac-address")"

🟢 In diesem Artikel wurde erläutert, wie das Auftreten eines unbekannten DHCP-Servers im lokalen Netzwerk (ein Problem in kleinen Netzwerken) festgestellt und eine Benachrichtigung per Telegramm oder E-Mail gesendet wird. Ich hoffe, dass Sie durch eine schnelle Möglichkeit, sich über einen nicht autorisierten DHCP-Server im lokalen Netzwerk zu informieren, schneller reagieren und Ihre Arbeit erleichtern können. Wenn Sie jedoch beim Einrichten auf Probleme stoßen, können Sie diese gerne in die Kommentare eintragen. Ich werde versuchen zu helfen.

Das Skript wird überprüft: hAP ac lite [RouterBOARD 952Ui-5ac2nD], RouterOS 6.47.8 (stable).

📒 Wenn Sie Materialien von der Seite kopieren, müssen Sie den Autor (Yun Sergey) und einen Hyperlink zur Quelle (MHelp.pro) angeben.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.