MikroTik-Skripte: Senden Sie eine Benachrichtigung, um das Gerät im Telegramm einzuschalten

Das MikroTik-Skript sendet eine Einschaltbenachrichtigung des Geräts an Telegram. Ermöglicht es Ihnen, sich über unerwartete Neustarts von Geräten oder Probleme mit der Stromversorgung von Geräten zu informieren, die das Überwachungssystem ergänzen.
Wenn Sie eine Nachricht an Telegram senden, wird das Ereignis auch in das Systemprotokoll geschrieben.

🔔 Damit das Skript funktioniert, müssen Sie über ein Telegramm-Bot-Token und eine Chat-ID oder eine persönliche ID verfügen. Das Erstellen eines Telegramm-Bots und das Abrufen der erforderlichen IDs ist nicht das Thema dieses Artikels.

Die Telegrammnachricht enthält:

  1. Gerätekennung;
  2. Informationsmeldung zum Gerätestart.

Artikel in anderen Sprachen:
🇺🇸 – Mikrotik Scripts: sending power on notification to Telegram
🇪🇸 – Mikrotik Scripts: envío de notificación de encendido a Telegram
🇷🇺 – MikroTik Скрипты: отправить уведомление о включении устройства в Telegram
🇫🇷 – Scripts Mikrotik: envoi d’une notification pour allumer l’appareil dans Telegram
🇳🇱 – MikroTik-scripts: melding over het inschakelen van het apparaat, bericht in Telegram

Gerät Identität ändern

Ändern Sie die Geräte-ID, um besser zu verstehen, welches Gerät die Anforderung sendet.

[System] -> [Identity]

oder

/system identity set name="WhiteHouseMikroTik"

Erstellen Sie eine Skriptbenachrichtigung zum Einschalten des Geräts

Das Skript erstellt die Variable RebootStatus.
Wenn die Variable RebootStatus keine Rolle spielt (was passiert, wenn das Skript zum ersten Mal gestartet wird), wird eine Nachricht an Telegram gesendet.
Dann wird die Variable RebootStatus auf True gesetzt.

Damit das Skript funktioniert, müssen Sie die folgenden Berechtigungen festlegen: Lesen, Schreiben, Richtlinien, Überprüfen.

[System] -> [Scripts] -> [+] -> [Name: CheckPowerOn] -> [Policy: read, write, policy, test]

Skriptcode:

# Func: Telegram send message
:local TGSendMessage do={
    :local tgUrl "https://api.telegram.org/bot$Token/sendMessage?chat_id=$ChatID&text=$Text&parse_mode=html";
    /tool fetch http-method=get url=$tgUrl keep-result=no;
}

# Constants
:global RebootStatus;
:local TelegramBotToken "987654321:AAFJIVTAWodBwzGX2CLne6-PK4RFNSy-8OY";
:local TelegramChatID "987654321";
:local DeviceName [/system identity get name];

:local TelegramMessageText "\F0\9F\9F\A2 <b>$DeviceName:</b> start after Power Off.";

# Program
:if ($RebootStatus != true)  do={
    $TGSendMessage Token=$TelegramBotToken ChatID=$TelegramChatID Text=$TelegramMessageText;
    :set RebootStatus true;
    :log info "Script CheckPowerOn send Telegram message."
}
MikroTik-Skripte: Senden Sie eine Benachrichtigung, um das Gerät im Telegramm einzuschalten

Add script launch to schedule

Damit das Skript funktioniert, müssen Sie die folgenden Berechtigungen festlegen: read, write, policy, test.

[System] -> [Schedule] -> [+] -> [Name: CheckPowerOn script] - > [Interval: 00:05:00] -> [Policy: read, write, policy, test]

Skriptcode:

/system script run CheckPowerOn
Hinzufügen eines Skripts zum Überprüfen des Gerätestarts und Senden einer Telegrammnachricht an den MikroTik-Taskplaner

Jetzt überprüft das Gerät alle 5 Minuten die Neustartvariable und sendet eine Benachrichtigung an Telegram, wenn das Gerät neu gestartet wurde.


🟢 In diesem Artikel wurde das Mikrotik-Skript zum Senden einer Benachrichtigung zum Einschalten eines Geräts in Telegram erläutert. Ich hoffe, dies hilft, die Kontrolle über Ihr MikroTik-Gerät zu verbessern. Wenn Sie jedoch beim Einrichten auf Probleme stoßen, können Sie diese gerne in die Kommentare eintragen. Ich werde versuchen zu helfen.

Das Skript wird überprüft: hAP ac lite [RouterBOARD 952Ui-5ac2nD], RouterOS 6.47.8 (stable).

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.