MikroTik: So deaktivieren (aktivieren) Sie die Schnittstelle nach einem Zeitplan

Wir werden verschiedene Möglichkeiten zum Deaktivieren (Aktivieren) der MikroTik-Netzwerkschnittstelle oder zum Deaktivieren des Internets nach einem Zeitplan analysieren: Firewall-Regel, NAT, MikroTik-Taskplaner oder MikroTik-Skript.

Inhalt

  1. Firewall-Regel: Deaktivieren (Aktivieren) einer Schnittstelle nach einem Zeitplan
  2. NAT: Wie man das Internet nach einem Zeitplan zulässt (verweigert)
  3. Scheduler: Deaktivieren (aktivieren) Sie die Schnittstelle nach Zeit
  4. MikroTik-Skript: Deaktivieren (Aktivieren) der Schnittstelle

Firewall-Regel: Deaktivieren (Aktivieren) einer Schnittstelle nach einem Zeitplan

Um die Schnittstelle nach einem Zeitplan zu deaktivieren oder zu deaktivieren, können Sie die Firewall-Regeleinstellung auf der Registerkarte Extra verwenden.

⚠️ Damit die Regel funktioniert, muss die Schnittstelle die Hauptschnittstelle (main) sein.

Beispiel: Wir werden den Betrieb der WiFi-Schnittstelle (wlan2-5GHz) außerhalb der Arbeitszeit von 19:00 bis 07:00 Uhr einschränken.

Erstellen Sie eine Regel:

[IP] -> [Firewall] -> [Filter Rules] -> [+] -> [General: Chain=forward, In. interface=wlan2-5GHz; Extra: Time=19:00:00-07:00:00; Comment="Blocking traffic on the interface, according to the schedule."]

im Terminal:

/ip firewall filter add action=reject chain=forward in-interface=wlan2-5GHz reject-with=icmp-network-unreachable time=9h-7h,sun,mon,tue,wed,thu,fri,sat comment="Blocking traffic on the interface, according to the schedule."

Wenn Sie den Betrieb der Schnittstelle am Samstag und Sonntag (ganzer Tag) deaktivieren möchten, stellen Sie die Zeitwerte ein:

[IP] -> [Firewall] -> [Filter Rules] -> [+] -> [General: Chain=forward, In. interface=wlan2-5GHz; Extra: Time=00:00:00-1d 00:00:00, Days=sun, sat; Comment="Blocking traffic on the interface, according to the schedule."]

im Terminal:

/ip firewall filter add action=drop chain=forward in-interface=wlan2-5GHz time=0s-1d,sun,sat comment="Blocking traffic on the interface, according to the schedule."
MikroTik Firewall-Regel: Deaktivieren (Aktivieren) einer Schnittstelle nach einem Zeitplan

NAT: Wie man das Internet nach einem Zeitplan zulässt (verweigert)

Mit der NAT-Regeleinstellung (Masquerade) können Sie den Zugriff auf das Internet nach Zeit verweigern (oder zulassen).

Bearbeiten Sie die Masquerade-Regel auf der Registerkarte Extra:

[IP] -> [Firewall] -> [NAT] -> [Extra: Time=19:00:00-07:00:00, Days: mon,tue,wed,thu,fri; Comment="Rule runs on schedule."]

im Terminal:

/ip firewall nat add action=masquerade chain=srcnat out-interface-list=ExternalInterfaces time=8h-20h,mon,tue,wed,thu,fri comment="Rule runs on schedule."
NAT: So lassen Sie das Internet nach einem Zeitplan zu (verweigern)

Scheduler: Deaktivieren (aktivieren) Sie die Schnittstelle nach Zeit

Schalten Sie die WiFi wlan2-5GHz-Schnittstelle nach 20:00:00 mit MikroTik Scheduler aus:

[System] -> [Schedule] -> [+] -> [Name: "Interface: Disable WiFi"; Start Time: 20:00:00; Interval: 1d 00:00:00; Policy: read, write, policy, test; text: "[/interface set wlan2-5GHz disabled=yes]"; Comment: Disable the interface at the specified time]

im Terminal:

/system scheduler add name="Interface: Disable WiFi" start-date=feb/22/2021 start-time=20:00:00 interval=1d on-event="[/interface set wlan2-5GHz disabled=yes]" policy=read,write,policy,test comment="Disable the interface at the specified time"

Aktivieren Sie die WiFi wlan2-5GHz-Schnittstelle ab 08:00:00 Uhr mit MikroTik Scheduler:

[System] -> [Schedule] -> [+] -> [Name: "Interface: Enable WiFi"; Start Time: 20:00:00; Interval: 1d 00:00:00; Policy: read, write, policy, test; text: "[/interface set wlan2-5GHz disabled=no]"; Comment: Disable the interface at the specified time]

im Terminal:

/system scheduler add name="Interface: Enable WiFi" start-date=feb/22/2021 start-time=08:00:00 interval=1d on-event="[/interface set wlan2-5GHz disabled=no]" policy=read,write,policy,test comment="Enable the interface at the specified time"
MikroTik Scheduler: Deaktivieren (aktivieren) Sie die Schnittstelle nach Zeit

MikroTik-Skript: Deaktivieren (Aktivieren) der Schnittstelle

Sie können die Schnittstelle auch mit hilfe des MikroTik-Skripts und des Taskplaners deaktivieren (oder aktivieren).

Skript erstellen

Geben Sie die folgenden Variablen im Skript an:

  1. InterfaceName – Schnittstellenname (im Beispiel wlan2-5GHz);
  2. StartEnableTime – Zeit, ab der die Schnittstelle eingeschaltet werden soll (im Beispiel 08:00:00);
  3. EndEnableTime – Zeit, nach der die Schnittstelle ausgeschaltet werden soll (im Beispiel 20:00:00).
[System] -> [Scripts] -> [+] -> [Name: WorkTimeInterface] -> [Policy: read, write, test, policy]

Skriptcode:

# Name: WorkTimeInterface v1
# Description: Enable or disable the selected interface on a schedule.
# Author: Yun Sergey [MHelp.pro] © 2021
# License: GPL-3.0 License
# Description, purpose and questions: https://mhelp.pro/mikrotik-how-to-disable-enable-the-interface-on-a-schedule/
# More scripts Mikrotik: https://mhelp.pro/tag/mikrotik-scripts/
# Verified: RouterBOARD 952Ui-5ac2nD, RouterOS 6.48.1 (stable)

:local InterfaceName wlan2-5GHz;
:local StartEnableTime [:totime "08:00:00"];
:local EndEnableTime [:totime "20:00:00"];

:local StatusInterface [/interface get $InterfaceName disabled];
:local CurrenTime [/system clock get time];

#:log info "Script WorkTimeInterface running. Interface $InterfaceName disabled: $StatusInterface.";

:if ( $StartEnableTime < $CurrenTime and $CurrenTime < $EndEnableTime) do={
    #:log info "Script WorkTimeInterface: work time.";
    :if  ($StatusInterface) do={
        [/interface set $InterfaceName disabled=no];
        :log info "Script WorkTimeInterface: interface $InterfaceName was disabled, enabled the interface.";
    } else={
        #:log info "Script WorkTimeInterface: skip enable interface, $InterfaceName already enabled.";
    };

} else={
    #:log info "Script WorkTimeInterface: not work time";
    :if  (!$StatusInterface) do={
        [/interface set $InterfaceName disabled=yes];
        :log info "Script WorkTimeInterface: interface $InterfaceName was enabled, disabled the interface."
    }
}
#:log info "Script WorkTimeInterface finished. Interface $InterfaceName disabled: $StatusInterface.";

Wenn das Skript nicht oder nicht ordnungsgemäß funktioniert, entfernen Sie das Symbol # vor dem Anfang der :log zeilen und überprüfen Sie das MikroTik-Protokoll, wenn Sie das Skript ausführen.

Fügen Sie dem Scheduler ein Skript hinzu

Geben Sie die Rechte an, um das Skript auszuführen: read, write, test, policy.

[System] -> [Schedule] -> [+] -> [Name: "Interface: Enable/Disable WiFi"; Start Time: 00:00:50; Interval: 00:15:00; Policy: read, write, policy, test; text: "[/system script run WorkTimeInterface]"; Comment: "Run script Enable/Disable interface"]
MikroTik-Skript: Deaktivieren (Aktivieren) der Schnittstelle

🟢 In diesem Artikel wurde erläutert, wie Sie die MikroTik-Schnittstelle nach einem Zeitplan deaktivieren (aktivieren) oder den Zugriff auf das Internet nach Zeit zulassen (verweigern). Ich hoffe, Sie haben einen geeigneten Weg gewählt, um den Status der Schnittstelle zu verwalten. Wenn Sie jedoch beim Einrichten auf Probleme stoßen, können Sie diese gerne in die Kommentare eintragen. Ich werde versuchen zu helfen.

Das Skript wird überprüft: hAP ac lite [RouterBOARD 952Ui-5ac2nD], RouterOS 6.48.1 (stable).

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Adblock
detector