MikroTik Firewall: Блокировка рекламы на сайтах

Блокируем рекламу в интернете используя возможности устройств MikroTik. Блокировку осуществляем с помощью адресного листа (со списком рекламных сетей) и правил Firewall.

Блокируем показ рекламных объявлений от основных рекламных сетей, но вы так же можете добавить свои рекламные сети (которые использованы на посещаемых сайтах).

Помните, что показ рекламных объявлений, является средством вознаграждения авторов сайта (например MHelp.pro).

Блокировка рекламных сетей так же может вызвать проблемы с входом в рекламные кабинеты на сайтах. Учтите это, если вы или ваши пользователи являются веб мастерами.

Содержание

  1. Создаем адрес лист
  2. Создаем правило Firewall
  3. Добавить адрес рекламной сетей в список блокировки
  4. Как найти рекламные сети на сайте
  5. Список популярных рекламных сетей

Статья на других языках:
🇺🇸 — MikroTik Firewall: Block ads on websites
🇪🇸 — MikroTik Firewall: Bloquear anuncios los sitios web
🇫🇷 — MikroTik Firewall: Bloquer les publicités sur les sites Web
🇩🇪 — MikroTik Firewall: Blockieren Sie Anzeigen auf Websites
🇳🇱 — MikroTik Firewall: Advertenties op websites blokkeren

Создаем адрес лист

Создадим адресный лист AdNetworks и добавим в него домены рекламных сетей.

[IP] -> [Firewall] -> [Address Lists] ->[+] -> [Name: AdNetworks ] -> [Comment: Blocking IP addresses of ad networks from this list.]

Используя терминал:

/ip firewall address-list add list="AdNetworks" comment="Blocking IP addresses of ad networks from this list."
MikroTik Firewall  Блокировка рекламы на сайтах. Создать список рекламных сетей для блокировки

Создаем правило Firewall

Создаем правило межсетевого экрана, которое при обнаружении трафика из рекламных сетей (список AdNetworks), помещает IP адрес рекламной сети в список блокировки — BlackList (из статьи «Защита MikroTik (базовая настройка безопасности устройств)«).

[IP] -> [Firewall] -> [Raw] -> [+] -> [General: Chain=prerouting; Advanced: Src. Address List=AdNetworks; Action: add src to address list=BlackList, Timeout=2d 00:00:00; Comment="Rule #25 \"AdNetworksList\": drop connections from ad networks."]

Используйте терминал:

/ip firewall raw add chain=prerouting src-address-list=AdNetworks  action=add-src-to-address-list address-list=BlackList address-list-timeout=2d comment="Rule #25 \"AdNetworksList\": drop connections from ad networks."

Разместите правило в таблице Raw, в соответствии с его номером в комментарии.

Правило Firewall MikroTik, для блокировки IP адресов из списка рекламных сетей

Добавляем адреса рекламных сетей в список блокировки

Google является самым популярным рекламодателем, если не желаете видеть эти рекламные объявления — заблокируйте следующие домены рекламной сети:

  • adservice.google.com;
  • tpc.googlesyndication.com.

Внесите домен в в адресный лист AdNetworks:

[IP] -> [Firewall] -> [Address Lists] ->[+] -> [Name: AdNetworks; Address: adservice.google.com] -> [Comment: * Google ads]
Добавляем доменные имена рекламных сетей в список блокировки

Таким же образом внесите и другие доменные имена или выполните в терминале:

/ip firewall address-list add address=tpc.googlesyndication.com list=AdNetworks comment="* Google ads"

Так же можно заблокировать сервис Google Tag Manager, который используется для добавления сторонних скриптов на веб страницу:

/ip firewall address-list add address=securepubads.g.doubleclick.net list=AdNetworks comment="* Google Tag Manager"

Если вы используете русскоязычные сайты, внесите в список блокировки местные рекламные сети Yandex и Relap:

/ip firewall address-list add address=an.yandex.ru list=AdNetworks comment="* Yandex ads"
/ip firewall address-list add address=relap.io list=AdNetworks comment="* Relap.io ads"

Для других стран можно внести в список блокировки, рекламную сеть Criteo:

/ip firewall address-list add address=static.criteo.net list=AdNetworks comment="* Criteo ads"

Я использую символ * в каждом комментарии, для фильтрации значений и удобного просмотра списка заблокированных сетей.

Показать список заблокированных рекламных сетей

Как найти рекламные сети на сайте

Инструкция для Google Chrome:

  1. Откройте страницу сайта с рекламой;
  2. Откройте Инструменты разработчика (клавиша F12 или сочетание Ctrl+Shift+I);
  3. Включите отображение Coverage в панели;
Как найти рекламные сети на сайте. Google Chrome включение Инструментов разработчика
  1. Нажмите кнопку Start instrumenting coverage and reload page;
Google Chrome включение Coverage в Инструментах разработчика
  1. Выполните фильтрацию по Javascript и сортировку по URL.
Google Chrome отображение скриптов рекламных сетей на сайте

Теперь вы можете видеть все скрипты используемые на этой веб странице и добавить в список AdNetworks скрипты с нежелательных доменных имен.

Я не рекомендую добавлять в список блокировки большое количество рекламных сетей — это может существенно увеличить нагрузку на CPU слабых роутеров. Но блокировка основных рекламных сетей может существенно снизить количество отображаемых блоков рекламы для всех устройств вашей сети (особенно для мобильных устройств).

Крупные рекламные сети (Google, Yandex) используют модерацию рекламных объявлений и устанавливают правила с ограничением на положение или количество рекламным блоков на странице. Возможно лучшим решением будет блокировка более «мусорных» рекламных сетей.

Рекламные объявления, являются способом дохода вебмастеров, мотивируя на создание качественного контента.

Список распространенных рекламных сетей (будет пополняться)

Мировые рекламные сети

Google, Criteo, Adsafeprotected, Onesignal, Admixer.

/ip firewall address-list add address=tpc.googlesyndication.com list=AdNetworks comment="* Google ads"
/ip firewall address-list add address=adservice.google.com list=AdNetworks comment="* Google ads"
/ip firewall address-list add address=static.criteo.net list=AdNetworks comment="* Criteo ads"
/ip firewall address-list add address=static.adsafeprotected.com list=AdNetworks comment="* Adsafeprotected ads"
/ip firewall address-list add address=cdn.adsafeprotected.com list=AdNetworks comment="* Adsafeprotected ads"
/ip firewall address-list add address=cdn.onesignal.com list=AdNetworks comment="* Onesignal ads"
/ip firewall address-list add address=cdn.admixer.net list=AdNetworks comment="* Admixer ads"

Русскоязычные рекламные сети

Yandex, Relap.

/ip firewall address-list add address=an.yandex.ru list=AdNetworks comment="* Yandex ads"
/ip firewall address-list add address=relap.io list=AdNetworks comment="* Relap.io ads"
/ip firewall address-list add address=yastatic.net list=AdNetworks comment="* Yandex Market ads"

Если вы нашли популярные рекламные сети (глобальные или региональные), напишите в комментариях, я добавлю правила в статью.


Помимо рекламных объявлений, на сайтах установлены системы аналитики нарушающие вашу приватность и собирающие данные, о блокировке систем аналитики и увеличении приватности в интернете, будет в следующей статье.

🟢 Как заблокировать рекламу на сайтах используя оборудование MikroTik обсуждалось в этой статье. Я надеюсь, что теперь вы сможете уменьшить количество отображаемых рекламных объявлений для устройств в вашей сети. Однако, если вы столкнетесь с каким-то проблемами при настройке, не стесняйтесь написать в комментариях. Я постараюсь помочь.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Adblock
detector