Scripts MikroTik: Envío de notificaciones y archivos por correo electrónico (función)

Otra opción de notificación por parte de dispositivos MikroTik es enviar notificaciones por correo electrónico.

Ejemplo de correo electrónico con dispositivo MikroTik
Ejemplo de correo electrónico con dispositivo MikroTik

Para configurar, necesita los parámetros SMTP de su servidor de correo. Si el servidor de correo usa autenticación de dos factores, use la clave de la aplicación en lugar de la contraseña (generalmente aparece en la mesa de ayuda del servicio de correo).

🔔 Si tiene la dirección IP del servidor SMTP y no cambia, especifíquela en el parámetro server. Si tiene un nombre de dominio de servidor SMTP con una IP dinámica, permita que MikroTik resuelva el nombre de dominio en una dirección IP usando la construcción [: resolve «smtp.mail.com»].

Artículo en otros idiomas:
🇺🇸 – MikroTik Scripts: Sending Notifications and Files to Email
🇷🇺 – MikroTik Скрипты: Отправить письмо и файл на почту
🇫🇷 – Scripts MikroTik: envoi de notifications et de fichiers par courrier électronique
🇩🇪 – MikroTik-Skripte: Senden von benachrichtigungen und daten an E-mails

Enviar correo electrónico desde MikroTik (opción simple)

Un script para enviar un correo electrónico y un archivo adjunto al correo especificado.

Script de una línea:

/tool e-mail send to=destination_mail@mail.com server=[:resolve "smtp.mail.com"] port=465 start-tls=tls-only user="source mail@mail.com" password="Password"  from="source mail@mail.com" subject="Subject" body="Simple Text" file="file_for_send.txt"

Secuencia de comandos de varias líneas (mejor legibilidad):

/tool e-mail send to=destination_mail@mail.com \
    server=[:resolve "smtp.mail.com"] port=465 start-tls=tls-only \
    user="source mail@mail.com" password="Password"  from="source mail@mail.com" \
    subject="Subject" body="Simple Text" \
    file="file_for_send.txt"

Enviar correo electrónico desde MikroTik (función)

Si utiliza el envío de notificaciones por correo electrónico desde muchas secuencias de comandos, le recomiendo que separe la secuencia de comandos en la función «Enviar correo electrónico» y la secuencia de comandos «Llamar a la función para enviar correo electrónico».

[System] -> [Scripts] -> [+] -> [Name: SendEmailFunction] -> [Policy: Don't require permissions]

Código de secuencia de comandos:

# Variables
:local SendFrom "source_mail@mail.com";
:local PasswordMail "Password";
:local SmtpServer [:resolve "smtp.mail.com"];
:local UserName "source_mail@mail.com";
:local SmtpPort 465;
:local UseTLS "tls-only";

# Main script code
/tool e-mail send to=$SendTo server=$SmtpServer port=$SmtpPort start-tls=$UseTLS user=$SendFrom password=$PasswordMail from=$SendFrom subject=$Subject body=$TextMail file=$FileName;
Scripts MikroTik: Envío de notificaciones y archivos por correo electrónico

Acceso a la función «Enviar correo»

[System] -> [Scripts] -> [+] -> [Name: SendEmailCall] -> [Policy: read, write, policy, test]

Especifique los parámetros que se pasarán a la función principal:

  • SendTo – dirección de envío de correo;
  • Subject – asunto del mensaje;
  • MessageText – texto del mensaje;
  • FileName – es el nombre del archivo (opcional).

Código de secuencia de comandos:

# Variables
:local DeviceName [/system identity get name];
:local Time [/system clock get time];
:local Date [/system clock get date];

:local SendTo "destination_mail@mail.com";
:local Subject "\F0\9F\9F\A2 INFO: $DeviceName [$Date $Time]";
:local MessageText "This informational message indicates the successful execution of the script on device $DeviceName";
:local FileName "some_file.txt";

# Main script code
:local SendEmail [:parse [/system script get SendEmailFunction source]];
$SendEmail SendTo=$SendTo TextMail=$MessageText Subject=$Subject FileName=$FileName;
Enviar correo electrónico de MikroTik

🟢 En este artículo se discutió cómo enviar un correo electrónico o un archivo desde un dispositivo MikroTik. Espero que ahora puedas enviar notificaciones desde dispositivos MikroTik por correo electrónico. Sin embargo, si tiene algún problema durante la configuración, no dude en escribir en los comentarios. Trataré de ayudar.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *