MikroTik-scripts: Melding over het inschakelen van het apparaat, bericht in Telegram

MikroTik-script stuurt een melding om het apparaat in te schakelen naar Telegram. Hiermee krijgt u informatie over onverwachte herstart van apparaten of stroomproblemen met apparatuur.
Wanneer u een bericht naar Telegram verzendt, wordt de gebeurtenis ook naar het systeemlogboek geschreven.

🔔 Om het script te laten werken, moet u een Telegram-bot-token en een chat-ID of een persoonlijke ID hebben. Het maken van een Telegram-bot en het verkrijgen van de vereiste ID is niet het onderwerp van dit artikel.

Het Telegram-bericht bevat:

  1. apparaat-ID;
  2. informatiebericht over het opstarten van het apparaat.

Artikel in andere talen:
🇺🇸 – Mikrotik Scripts: sending power on notification to Telegram
🇪🇸 – Mikrotik Scripts: envío de notificación de encendido a Telegram
🇷🇺 – MikroTik Скрипты: отправить уведомление о включении устройства в Telegram
🇫🇷 – Scripts Mikrotik: envoi d’une notification pour allumer l’appareil dans Telegram
🇩🇪 – MikroTik-Skripte: Senden Sie eine Benachrichtigung, um das Gerät im Telegramm einzuschalten

Verander de apparaat-ID

Wijzig de apparaat-ID om te begrijpen welk apparaat het bericht verzendt.

[System] -> [Identity]

of

/system identity set name="WhiteHouseMikroTik"

Maak een script melding over het opstarten van het apparaat

Het script maakt de variabele RebootStatus. Als de variabele opnieuw wordt opgestart, wordt RebootStatus ingesteld op True.

Om het script te laten werken, moet u de volgende machtigingen instellen: read, write, policy, test.

[System] -> [Scripts] -> [+] -> [Name: CheckPowerOn] -> [Policy: read, write, policy, test]

Scriptcode:

# Func: Telegram send message
:local TGSendMessage do={
    :local tgUrl "https://api.telegram.org/bot$Token/sendMessage?chat_id=$ChatID&text=$Text&parse_mode=html";
    /tool fetch http-method=get url=$tgUrl keep-result=no;
}

# Constants
:global RebootStatus;
:local TelegramBotToken "987654321:AAFJIVTAWodBwzGX2CLne6-PK4RFNSy-8OY";
:local TelegramChatID "987654321";
:local DeviceName [/system identity get name];

:local TelegramMessageText "\F0\9F\9F\A2 <b>$DeviceName:</b> start after Power Off.";

# Program
:if ($RebootStatus != true)  do={
    $TGSendMessage Token=$TelegramBotToken ChatID=$TelegramChatID Text=$TelegramMessageText;
    :set RebootStatus true;
    :log info "Script CheckPowerOn send Telegram message."
}
MikroTik-scripts: Telegram-melding om het apparaat in te schakelen

Voeg scriptstart toe aan planning

Om het script te laten werken, moet u de volgende machtigingen instellen: read, write, policy, test.

[System] -> [Schedule] -> [+] -> [Name: CheckPowerOn script] - > [Interval: 00:05:00] -> [Policy: read, write, policy, test]

Scriptcode:

/system script run CheckPowerOn
 Добавление скрипта проверки запуска устройства и отправки сообщения Телеграм, в планировщик заданий MikroTik

Nu controleert het apparaat elke 5 minuten de reboot-variabele en stuurt het een melding naar Telegram als het apparaat opnieuw is opgestart.


🟢 Mikrotik-script voor het verzenden van een melding over het inschakelen van een apparaat in Telegram werd in dit artikel besproken. Ik hoop dat dit helpt om de controle over je MikroTik te vergroten. Als u echter problemen ondervindt bij het instellen, kunt u een bericht schrijven in de vorm van een opmerking die ik zal proberen te helpen.

Het script wordt gecontroleerd: hAP ac lite [RouterBOARD 952Ui-5ac2nD], RouterOS 6.47.8 (stabiel).

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *

Adblock
detector