MikroTik: Cómo deshabilitar (habilitar) la interfaz en un horario

Analizaremos varias formas de deshabilitar (habilitar) la interfaz de red MikroTik o deshabilitar Internet, según un cronograma: regla de firewall, NAT, programador de tareas MikroTik o script MikroTik.

Contenido

  1. Regla de Firewall: cómo deshabilitar (habilitar) una interfaz en un horario
  2. NAT: cómo permitir (denegar) Internet en un horario
  3. Programador: deshabilita (habilita) la interfaz por tiempo
  4. Script MikroTik: cómo deshabilitar (habilitar) la interfaz

Artículo en otros idiomas:
🇺🇸 – MikroTik: How to disable (enable) the interface on a schedule
🇷🇺 – MikroTik: Как отключить (включить) интерфейс по расписанию
🇫🇷 – MikroTik: Comment désactiver (activer) l’interface selon un calendrier
🇩🇪 – MikroTik: So deaktivieren (aktivieren) Sie die Schnittstelle nach einem Zeitplan
🇳🇱 – MikroTik: Hoe de interface volgens een schema uit te schakelen (in te schakelen)

Regla de Firewall: cómo deshabilitar (habilitar) una interfaz en un horario

Para deshabilitar o deshabilitar la interfaz en un horario, puede usar la configuración de la regla de Firewall en la pestaña Extra.

⚠️ Para que la regla funciona, la interfaz debe ser la interfaz principal (main).

Por ejemplo: restringiremos el funcionamiento de la interfaz WiFi (wlan2-5GHz) fuera del horario laboral, de 19:00 a 07:00.

Crea una regla:

[IP] -> [Firewall] -> [Filter Rules] -> [+] -> [General: Chain=forward, In. interface=wlan2-5GHz; Extra: Time=19:00:00-07:00:00; Comment="Blocking traffic on the interface, according to the schedule."]

en terminal:

/ip firewall filter add action=reject chain=forward in-interface=wlan2-5GHz reject-with=icmp-network-unreachable time=9h-7h,sun,mon,tue,wed,thu,fri,sat comment="Blocking traffic on the interface, according to the schedule."

Si desea deshabilitar el funcionamiento de la interfaz los sábados y domingos (día completo), configure los valores de tiempo:

[IP] -> [Firewall] -> [Filter Rules] -> [+] -> [General: Chain=forward, In. interface=wlan2-5GHz; Extra: Time=00:00:00-1d 00:00:00, Days=sun, sat; Comment="Blocking traffic on the interface, according to the schedule."]

en terminal:

/ip firewall filter add action=drop chain=forward in-interface=wlan2-5GHz time=0s-1d,sun,sat comment="Blocking traffic on the interface, according to the schedule."
MikroTik: Cómo deshabilitar (habilitar) la interfaz en un horario

NAT: cómo permitir (denegar) Internet en un horario

Puede denegar (o permitir) el acceso a Internet por tiempo utilizando la configuración de la regla de enmascaramiento (NAT).

Edite la regla de la masquerade, en la pestaña Extra:

[IP] -> [Firewall] -> [NAT] -> [Extra: Time=19:00:00-07:00:00, Days: mon,tue,wed,thu,fri; Comment="Rule runs on schedule."]

en terminal:

/ip firewall nat add action=masquerade chain=srcnat out-interface-list=ExternalInterfaces time=8h-20h,mon,tue,wed,thu,fri comment="Rule runs on schedule."
NAT: Cómo permitir (denegar) Internet en un horario

Programador: deshabilita (habilita) la interfaz por tiempo

Apague la interfaz WiFi wlan2-5GHz después de las 20:00:00 usando MikroTik Scheduler:

[System] -> [Schedule] -> [+] -> [Name: "Interface: Disable WiFi"; Start Time: 20:00:00; Interval: 1d 00:00:00; Policy: read, write, policy, test; text: "[/interface set wlan2-5GHz disabled=yes]"; Comment: Disable the interface at the specified time]

en terminal:

/system scheduler add name="Interface: Disable WiFi" start-date=feb/22/2021 start-time=20:00:00 interval=1d on-event="[/interface set wlan2-5GHz disabled=yes]" policy=read,write,policy,test comment="Disable the interface at the specified time"

Habilite la interfaz WiFi wlan2-5GHz desde las 08:00:00 usando MikroTik Scheduler:

[System] -> [Schedule] -> [+] -> [Name: "Interface: Enable WiFi"; Start Time: 20:00:00; Interval: 1d 00:00:00; Policy: read, write, policy, test; text: "[/interface set wlan2-5GHz disabled=no]"; Comment: Disable the interface at the specified time]

en terminal:

/system scheduler add name="Interface: Enable WiFi" start-date=feb/22/2021 start-time=08:00:00 interval=1d on-event="[/interface set wlan2-5GHz disabled=no]" policy=read,write,policy,test comment="Enable the interface at the specified time"
Programador MikroTik: apague (encienda) la interfaz por tiempo

Script MikroTik: cómo deshabilitar (habilitar) la interfaz

También puede deshabilitar (o habilitar) la interfaz usando el script MikroTik y el Programador de tareas.

Crear guion

Especifique las siguientes variables en el script:

  1. InterfaceName – nombre de la interfaz (en el ejemplo wlan2-5GHz);
  2. StartEnableTime – hora, a partir de la cual se debe encender la interfaz (en el ejemplo 08:00:00);
  3. EndEnableTime – tiempo, después del cual la interfaz debe apagarse (en el ejemplo 20:00:00).
[System] -> [Scripts] -> [+] -> [Name: WorkTimeInterface] -> [Policy: read, write, test, policy]

Script code:

# Name: WorkTimeInterface v1
# Description: Enable or disable the selected interface on a schedule.
# Author: Yun Sergey [MHelp.pro] © 2021
# License: GPL-3.0 License
# Description, purpose and questions: https://mhelp.pro/mikrotik-how-to-disable-enable-the-interface-on-a-schedule/
# More scripts Mikrotik: https://mhelp.pro/tag/mikrotik-scripts/
# Verified: RouterBOARD 952Ui-5ac2nD, RouterOS 6.48.1 (stable)

:local InterfaceName wlan2-5GHz;
:local StartEnableTime [:totime "08:00:00"];
:local EndEnableTime [:totime "20:00:00"];

:local StatusInterface [/interface get $InterfaceName disabled];
:local CurrenTime [/system clock get time];

#:log info "Script WorkTimeInterface running. Interface $InterfaceName disabled: $StatusInterface.";

:if ( $StartEnableTime < $CurrenTime and $CurrenTime < $EndEnableTime) do={
    #:log info "Script WorkTimeInterface: work time.";
    :if  ($StatusInterface) do={
        [/interface set $InterfaceName disabled=no];
        :log info "Script WorkTimeInterface: interface $InterfaceName was disabled, enabled the interface.";
    } else={
        #:log info "Script WorkTimeInterface: skip enable interface, $InterfaceName already enabled.";
    };

} else={
    #:log info "Script WorkTimeInterface: not work time";
    :if  (!$StatusInterface) do={
        [/interface set $InterfaceName disabled=yes];
        :log info "Script WorkTimeInterface: interface $InterfaceName was enabled, disabled the interface."
    }
}
#:log info "Script WorkTimeInterface finished. Interface $InterfaceName disabled: $StatusInterface.";

Si la secuencia de comandos no funciona o no funciona correctamente, descomente las líneas :log (elimine el símbolo # al principio de la línea) y verifique el registro de MikroTik cuando se inicie la secuencia de comandos.

Add script to Scheduler

Para ejecutar el script, necesita permiso: read, write, test, policy.

[System] -> [Schedule] -> [+] -> [Name: "Interface: Enable/Disable WiFi"; Start Time: 00:00:50; Interval: 00:15:00; Policy: read, write, policy, test; text: "[/system script run WorkTimeInterface]"; Comment: "Run script Enable/Disable interface"]
MikroTik Script: Cómo deshabilitar (habilitar) la interfaz

🟢 En este artículo se discutió cómo deshabilitar (habilitar) la interfaz MikroTik en un horario o permitir (denegar) el acceso a Internet por tiempo. Espero que haya elegido una forma adecuada de administrar el estado de la interfaz. Sin embargo, si tiene algún problema durante la configuración, no dude en escribir en los comentarios. Trataré de ayudar.

El guión está verificado: hAP ac lite [RouterBOARD 952Ui-5ac2nD], RouterOS 6.48.1 (stable).

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Adblock
detector