MikroTik Scripts: Mise à jour automatique du micrologiciel RouterBOARD

Script pour mettre à jour automatiquement le firmware MikroTik (bootloader) après la mise à jour de la version RouterOS, de sorte que les versions de la version MikroTik RouterOS et du bootloader RouterBOARD correspondent.

Auparavant, je devais mettre à jour manuellement la version du chargeur de démarrage RouterBOARD, après la mise à jour de la version RouterOS, cela nécessitait du temps et de l’attention supplémentaires lorsqu’il y avait beaucoup d’appareils MikroTik. J’ai écrit un script pour automatiser ce processus.

Autres langues:

La description

Le script s’exécute 2 minutes plus tard (délai de 180 secondes) après le démarrage de l’appareil MikroTik. La version du micrologiciel RouterBOARD utilisée (current-firmware) et la version du RouterBOARD proposée pour la mise à niveau (upgrade-firmware) sont comparées. Si les versions ne correspondent pas, l’appareil MikroTik télécharge la version mise à jour du micrologiciel RouterBOARD et redémarre l’appareil après avoir installé la nouvelle version du micrologiciel.

✏️ Remarque : vérifiez qu’après le temps de pause spécifié avant le démarrage du script, Internet aura vraiment le temps de se connecter ou d’augmenter le délai avant l’exécution du script.

Créer un script (manuellement)

Ce script doit s’exécuter dès que l’appareil démarre, nous créons donc le script dans le planificateur de tâches, pas dans le magasin de scripts.

Menu

[System] - [Scheduler] - [+]

Données de script

Name: AutoUpgradeFirmware
Start Time: startup
Policy: read, policy, reboot, write

Script

:delay 180s;
/system/routerboard
:if ([get current-firmware] != [get upgrade-firmware]) do={
    upgrade;
    /system/reboot;
    }
Script de mise à niveau automatique du micrologiciel MikroTik RouterBOARD

Créer un script (automatiquement)

/system scheduler
add name=AutoUpgradeFirmware on-event=":delay 180s;\r\
    \n/system/routerboard\r\
    \n:if ([get current-firmware] != [get upgrade-firmware]) do={\r\
    \n    upgrade;\r\
    \n    /system/reboot;\r\
    \n    }" policy=reboot,read,write,policy start-time=startup

Now the firmware version of the device (bootloader) is always the same as the version of RouterOS, and I don’t have to waste time manually updating the firmware.

Script testé : RouterOS v7


🟢 Le script de mise à jour automatique du micrologiciel d’un appareil MikroTik lorsque la version de RouterOS installée est modifiée a été abordé dans cet article. J’espère que vous pouvez maintenant automatiser la tâche de mise à niveau de RouterOS et de la version du chargeur de démarrage de l’appareil. Cependant, si vous rencontrez des problèmes lors de la configuration du script, n’hésitez pas à écrire dans les commentaires. Je vais essayer d’aider.

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Adblock
detector