Scripts MikroTik: Atualização automática do firmware RouterBOARD

Script para atualizar automaticamente o firmware do MikroTik (bootloader) após atualizar a versão do RouterOS para que a versão do bootloader do MikroTik RouterOS e a versão do RouterBOARD correspondam.

Anteriormente, eu tinha que atualizar manualmente a versão do bootloader do RouterBOARD, depois de atualizar a versão do RouterOS, isso exigia tempo e atenção adicionais quando havia muitos dispositivos MikroTik. Eu escrevi um script para automatizar esse processo.

Outras línguas:

Descrição

O script é executado 2 minutos depois (atraso de 180 segundos) após a inicialização do dispositivo MikroTik. A versão de firmware do RouterBOARD usada (current-firmware) e a versão do RouterBOARD oferecida para atualização (upgrade-firmware) são comparadas. Se as versões não corresponderem, o dispositivo MikroTik baixa a versão atualizada do firmware RouterBOARD e reinicializa o dispositivo após instalar a nova versão do firmware.

✏️ Observação: verifique se após o tempo de pausa especificado antes do início do script, a Internet realmente terá tempo para se conectar ou aumentar o atraso antes da execução do script.

Criar script (manualmente)

Esse script deve ser executado assim que o dispositivo for inicializado, portanto, criamos o script no agendador de tarefas, não no repositório de scripts.

Cardápio

[System] - [Scheduler] - [+]

Dados do script

Name: AutoUpgradeFirmware
Start Time: startup
Policy: read, policy, reboot, write.

Script

:delay 180s;
/system/routerboard
:if ([get current-firmware] != [get upgrade-firmware]) do={
    upgrade;
    /system/reboot;
    }
Script de atualização automática de firmware MikroTik RouterBOARD

Criar script (automaticamente)

/system scheduler
add name=AutoUpgradeFirmware on-event=":delay 180s;\r\
    \n/system/routerboard\r\
    \n:if ([get current-firmware] != [get upgrade-firmware]) do={\r\
    \n    upgrade;\r\
    \n    /system/reboot;\r\
    \n    }" policy=reboot,read,write,policy start-time=startup

Agora a versão do firmware do dispositivo (bootloader) é sempre a mesma do RouterOS, e não preciso perder tempo atualizando manualmente o firmware.

Script testado: RouterOS v7


🟢 O script para atualizar automaticamente o firmware de um dispositivo MikroTik quando a versão do RouterOS instalada é alterada foi discutido neste artigo. Espero que agora você possa automatizar a tarefa de atualizar o RouterOS e a versão do bootloader do dispositivo. No entanto, se você encontrar algum problema ao configurar o script, sinta-se à vontade para escrever nos comentários. Eu tentarei ajudar.

Deixe uma resposta

O seu endereço de email não será publicado.

Adblock
detector