Skrip MikroTik: RouterBOARD firmware auto upgrade

Skrip untuk mengemas kini firmware (pemuat but) MikroTik secara automatik selepas mengemas kini versi RouterOS supaya versi MikroTik RouterOS dan pemuat but RouterBOARD sepadan.

Sebelum ini, saya terpaksa menaik taraf versi pemuat but RouterBOARD secara manual, selepas mengemas kini versi RouterOS, ini memerlukan masa dan perhatian tambahan apabila terdapat banyak peranti MikroTik. Saya menulis skrip untuk mengautomasikan proses ini.

Bahasa lain:

Penerangan

Skrip berjalan 2 minit kemudian (kelewatan 180 saat) selepas boot peranti MikroTik. Versi perisian tegar RouterBOARD yang digunakan (current-firmware) dan versi RouterBOARD yang ditawarkan untuk naik taraf (upgrade-firmware) dibandingkan. Jika versi tidak sepadan, peranti MikroTik memuat turun versi terkini perisian tegar RouterBOARD dan but semula peranti selepas memasang versi perisian tegar baharu.

✏️ Nota: semak bahawa selepas masa jeda yang ditentukan sebelum skrip bermula, Internet akan benar-benar mempunyai masa untuk menyambung atau meningkatkan kelewatan sebelum skrip berjalan.

Buat skrip (secara manual)

Skrip ini harus dijalankan sebaik sahaja peranti but, jadi kami mencipta skrip dalam penjadual tugas, bukan dalam stor skrip.

Menu

[System] - [Scheduler] - [+]

Data Skrip

Name: AutoUpgradeFirmware
Start Time: startup
Policy: read, policy, reboot, write.

Skrip

:delay 180s;
/system/routerboard
:if ([get current-firmware] != [get upgrade-firmware]) do={
    upgrade;
    /system/reboot;
    }
Skrip naik taraf auto perisian tegar MikroTik RouterBOARD

Buat skrip (secara automatik)

/system scheduler
add name=AutoUpgradeFirmware on-event=":delay 180s;\r\
    \n/system/routerboard\r\
    \n:if ([get current-firmware] != [get upgrade-firmware]) do={\r\
    \n    upgrade;\r\
    \n    /system/reboot;\r\
    \n    }" policy=reboot,read,write,policy start-time=startup

Kini versi perisian tegar peranti (pemuat but) sentiasa sama dengan versi RouterOS, dan saya tidak perlu meluangkan masa untuk mengemas kini perisian tegar secara manual.

Skrip diuji: RouterOS v7


🟢 Skrip untuk mengemas kini perisian tegar peranti MikroTik secara automatik apabila versi RouterOS yang dipasang diubah telah dibincangkan dalam artikel ini. Saya harap anda kini boleh mengautomasikan tugas menaik taraf RouterOS dan versi pemuat but peranti. Walau bagaimanapun, jika anda menghadapi sebarang masalah semasa menyediakan skrip, sila tulis dalam ulasan. Saya akan cuba membantu.

Tinggalkan Balasan

Alamat e-mel anda tidak akan disiarkan.

Adblock
detector