MikroTik Scripts: Notificación de la conexión del dispositivo a la red

Configuramos una notificación sobre la conexión de un nuevo dispositivo a una red local o WiFi usando la configuración del servidor DHCP (asignación de una dirección IP o vencimiento del arrendamiento). Enviamos un mensaje a Telegram o correo electrónico.

Mi enrutador wifi dice que un hombre estaba en casa con mi esposa mientras yo estaba en el trabajo

 LickingWoundSalt (Reddit)

Pero esta no es la única aplicación de esta posibilidad. 🙂

Si establece el tiempo de concesión de la dirección IP (Tiempo de concesión) igual a 10 horas, puede averiguar a qué hora se conectaron las computadoras de los empleados a la red o quién no apaga la computadora al salir del lugar de trabajo.

Si usa una contraseña de WiFi simple, es posible que el hijo del vecino también esté usando su WiFi. 🙂

El script le ayudará a conocer los problemas existentes con la estabilidad de la conexión o los problemas de la red.

También puede configurar otras acciones al activar este script.

Artículo en otros idiomas:
🇺🇸 – MikroTik Scripts: Notification of device connection to the network
🇷🇺 – MikroTik Скрипты: Уведомление о подключении устройства к сети
🇫🇷 – Scripts MikroTik: notification de la connexion de l’appareil au réseau
🇩🇪 – MikroTik-Scripts: Benachrichtigung über die Geräteverbindung zum Netzwerk
🇳🇱 – MikroTik-scripts: Melding van apparaat verbinding met het netwerk

Script: envío de una notificación cuando un dispositivo está conectado a la red

El script Mikrotik se ejecuta cuando se asigna una dirección IP a un nuevo dispositivo o un dispositivo cuya dirección IP ha expirado. El guión enviará un mensaje de Telegram o un correo electrónico.

El mensaje contiene:

  1. nombre del dispositivo (nombre de la computadora o asignado por el fabricante);
  2. comentario (si al dispositivo se le asigna una dirección estática con el comentario especificado);
  3. Nombre de la interfaz DHCP;
  4. Dirección IP y MAC del dispositivo conectado.

🔔 ¡Recomiendo usar solo caracteres en inglés en los comentarios de los dispositivos!

El script usa llamadas a funciones:
MikroTik Scripts: Sending a message to Telegram (function)
MikroTik Scripts: Sending Notifications and Files to Email (function)

Un ejemplo de una carta del servidor DHCP: se conecta un nuevo dispositivo
Un ejemplo de una carta del servidor DHCP: se conecta un nuevo dispositivo

Cambiar el tiempo de concesión de la dirección IP

Establezca el tiempo de concesión para la dirección IP = 10 horas.

[IP] -> [DHCP Server] -> [Your DHCP server] -> [General: Lease Time=10:00:00]

Crear secuencia de comandos de notificación

[IP] -> [DHCP Server] -> [Script]

Código de secuencia de comandos

:if ($leaseBound =1) do={
    # Variables
    :local Time [/system clock get time];
    :local Date [/system clock get date];
    :local Comment [/ip dhcp-server lease get value-name=comment number=[/ip dhcp-server lease find address=$leaseActIP]]
    :local DeviceName [/system identity get name];

    # START Send Telegram Module
    :local MessageText "\F0\9F\9F\A2 <b>$DeviceName: New DHCP client</b> %0D%0A <b>Name:</b> $"lease-hostname" %0D%0A <b>Comment:</b> [$Comment] %0D%0A <b>Interface:</b> $leaseServerName %0D%0A <b>IP:</b> $leaseActIP %0D%0A <b>MAC:</b> $leaseActMAC";
    :local SendTelegramMessage [:parse [/system script  get MyTGBotSendMessage source]]; 
    $SendTelegramMessage MessageText=$MessageText;
    #END Send Telegram Module

    # START Send Email Module
    :local SendTo "notify@mhelp.pro";
    :local Subject "\F0\9F\9F\A2 INFO: $DeviceName [$Date $Time] New DHCP client";
    :local MessageText "Name: $"lease-hostname", Comment: $Comment, Interface: $leaseServerName IP: $leaseActIP MAC: $leaseActMAC";
    :local FileName "";
    :local SendEmail [:parse [/system script get SendEmailFunction source]];
    $SendEmail SendTo=$SendTo TextMail=$MessageText Subject=$Subject FileName=$FileName;
    # END Send Email Module
}
MikroTik Scripts: Notificación de la conexión del dispositivo a la red

🟢 Este artículo discutió cómo crear un script MikroTik para enviar mensajes sobre la conexión de red de un dispositivo. Espero que hayas podido configurar el envío de notificaciones a Telegram o correo electrónico. Sin embargo, si tiene algún problema para obtener información, no dude en escribir en los comentarios. Trataré de ayudar.

Se verifica el script: hAP ac lite [RouterBOARD 952Ui-5ac2nD], RouterOS 6.47.8 (estable).

P.S. Si tiene un uso interesante o inusual del script, escriba en los comentarios, lo agregaré al artículo. 🙂

📒 Al copiar materiales del sitio, debe indicar el autor (Yun Sergey) y un hipervínculo a la fuente (MHelp.pro).

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *