Scripts MikroTik: notification de la connexion de l’appareil au réseau

Nous mettons en place une notification de connexion d’un nouvel appareil à un réseau local ou WiFi en utilisant les paramètres du serveur DHCP (attribution d’une adresse IP ou expiration du bail). Nous envoyons un message à Telegram ou par e-mail.

Mon routeur wifi indique qu’un homme était à la maison avec ma femme pendant que j’étais au travail

 LickingWoundSalt (Reddit)

Mais ce n’est pas la seule application de cette possibilité. 🙂

Si vous définissez la durée de bail de l’adresse IP (Lease Time) sur 10 heures, vous pouvez savoir à quelle heure les ordinateurs des employés ont été connectés au réseau ou qui n’éteint pas l’ordinateur en quittant le lieu de travail.

Si vous utilisez un simple mot de passe WiFi, vous constaterez peut-être que l’enfant du voisin utilise également votre WiFi. 🙂

Le script vous aidera à découvrir les problèmes existants de stabilité de la connexion ou les problèmes de réseau.

Vous pouvez également configurer d’autres actions lors de l’activation de ce script.

Article dans d’autres langues:
🇺🇸 – MikroTik Scripts: Notification of device connection to the network
🇪🇸 – MikroTik Scripts: Notificación de la conexión del dispositivo a la red
🇷🇺 – MikroTik Скрипты: Уведомление о подключении устройства к сети
🇩🇪 – MikroTik-Scripts: Benachrichtigung über die Geräteverbindung zum Netzwerk
🇳🇱 – MikroTik-scripts: Melding van apparaat verbinding met het netwerk

Script: envoi d’une notification lorsqu’un appareil est connecté au réseau

Le script Mikrotik est déclenché lorsqu’une adresse IP est attribuée à un nouvel appareil ou à un appareil dont l’adresse IP a expiré. Envoie un message ou un e-mail Telegram.

Le message contient:

  1. nom de l’appareil (nom de l’ordinateur ou attribué par le fabricant);
  2. commentaire (si une adresse statique est attribuée à l’appareil avec le commentaire spécifié);
  3. Nom de l’interface DHCP;
  4. Adresse IP et MAC de l’appareil connecté.

🔔 Dans les commentaire des appareils, je recommande d’utiliser uniquement des caractères anglais!

Le script utilise des appels de fonction:
Scripts MikroTik: envoi de notifications et de fichiers par courrier électronique (fonction);
Scripts MikroTik: Envoi d’un message à Telegram (fonction).

Exemple d'e-mail de connexion de périphérique à partir du serveur DHCP
Exemple d’e-mail de connexion de périphérique à partir du serveur DHCP

Modifier la durée de bail de l’adresse IP

Définissez la durée du bail pour l’adresse IP = 10 heures.

[IP] -> [DHCP Server] -> [Your DHCP server] -> [General: Lease Time=10:00:00]

Créer un script de notification

[IP] -> [DHCP Server] -> [Script]

Code de script

:if ($leaseBound =1) do={
    # Variables
    :local Time [/system clock get time];
    :local Date [/system clock get date];
    :local Comment [/ip dhcp-server lease get value-name=comment number=[/ip dhcp-server lease find address=$leaseActIP]]
    :local DeviceName [/system identity get name];

    # START Send Telegram Module
    :local MessageText "\F0\9F\9F\A2 <b>$DeviceName: New DHCP client</b> %0D%0A <b>Name:</b> $"lease-hostname" %0D%0A <b>Comment:</b> [$Comment] %0D%0A <b>Interface:</b> $leaseServerName %0D%0A <b>IP:</b> $leaseActIP %0D%0A <b>MAC:</b> $leaseActMAC";
    :local SendTelegramMessage [:parse [/system script  get MyTGBotSendMessage source]]; 
    $SendTelegramMessage MessageText=$MessageText;
    #END Send Telegram Module

    # START Send Email Module
    :local SendTo "notify@mhelp.pro";
    :local Subject "\F0\9F\9F\A2 INFO: $DeviceName [$Date $Time] New DHCP client";
    :local MessageText "Name: $"lease-hostname", Comment: $Comment, Interface: $leaseServerName IP: $leaseActIP MAC: $leaseActMAC";
    :local FileName "";
    :local SendEmail [:parse [/system script get SendEmailFunction source]];
    $SendEmail SendTo=$SendTo TextMail=$MessageText Subject=$Subject FileName=$FileName;
    # END Send Email Module
}
Scripts MikroTik: notification de la connexion de l'appareil au réseau

🟢 Cet article explique comment créer un script MikroTik pour envoyer des messages sur la connexion réseau d’un appareil. J’espère que vous avez réussi à configurer l’envoi de notifications à Telegram ou par courrier électronique. Cependant, si vous rencontrez des problèmes pour obtenir des informations, n’hésitez pas à écrire dans les commentaires. J’essaierai d’aider.

Le script est vérifié: hAP ac lite [RouterBOARD 952Ui-5ac2nD], RouterOS 6.47.8 (stable).

P.S. Si vous avez une utilisation intéressante ou inhabituelle du script, écrivez dans les commentaires, j’ajouterai à l’article. 🙂

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Adblock
detector