MikroTik-scripts: Melding van apparaat verbinding met het netwerk

We zetten een melding op over de verbinding van een nieuw apparaat met een lokaal netwerk of wifi met behulp van de DHCP-serverinstellingen (toewijzing van een IP-adres of vervaldatum van de lease). We sturen een bericht naar Telegram of e-mail.

Mijn wifi-router zegt dat er een vreemde thuis was met mijn vrouw terwijl ik aan het werk was

 LickingWoundSalt (Reddit)

Maar dit is niet de enige toepassing van deze mogelijkheid. 🙂

Als je de leasetijd van het IP-adres (Leasetijd) instelt op 10 uur, kun je achterhalen hoe laat de computers van de medewerkers op het netwerk waren aangesloten of wie de computer niet uitschakelt bij het verlaten van de werkplek.

Als u een eenvoudig wifi-wachtwoord gebruikt, kan het zijn dat het kind van de buurman uw wifi gebruikt. 🙂

Het script helpt u bij het vinden van bestaande problemen met de verbindingsstabiliteit of netwerkproblemen.

U kunt ook andere acties configureren wanneer u dit script activeert.

Artikel in andere talen:
🇺🇸 – MikroTik Scripts: Notification of device connection to the network
🇷🇺 – MikroTik Скрипты: Уведомление о подключении устройства к сети
🇪🇸 – MikroTik Scripts: Notificación de la conexión del dispositivo a la red
🇫🇷 – Scripts MikroTik: notification de la connexion de l’appareil au réseau
🇩🇪 – MikroTik-Scripts: Benachrichtigung über die Geräteverbindung zum Netzwerk

Script: een melding verzenden wanneer een apparaat is verbonden met het netwerk

Mikrotik-script wordt geactiveerd wanneer een IP-adres wordt toegewezen aan een nieuw apparaat of een apparaat waarvan het IP-adres is verlopen. Stuurt een Telegram-bericht of e-mail.

Het bericht bevat:

  1. apparaatnaam (computernaam of toegewezen door de fabrikant);
  2. opmerking (als het apparaat een statisch adres krijgt toegewezen met de opgegeven opmerking);
  3. DHCP-interfacenaam;
  4. IP- en MAC-adres van het aangesloten apparaat.

🔔 Ik raad aan om alleen Engelse tekens te gebruiken in de opmerkingen bij de apparaten!

Het script gebruikt functie aanroepen:

Voorbeeld-e-mail van DHCP-server - nieuw apparaat aangesloten
Voorbeeld-e-mail van DHCP-server – nieuw apparaat aangesloten

Wijzig de leasetijd van het IP-adres

Stel de leasetijd in voor het IP-adres = 10 uur.

[IP] -> [DHCP Server] -> [Your DHCP server] -> [General: Lease Time=10:00:00]

Maak een melding script

[IP] -> [DHCP Server] -> [Script]

Scriptcode

:if ($leaseBound =1) do={
    # Variables
    :local Time [/system clock get time];
    :local Date [/system clock get date];
    :local Comment [/ip dhcp-server lease get value-name=comment number=[/ip dhcp-server lease find address=$leaseActIP]]
    :local DeviceName [/system identity get name];

    # START Send Telegram Module
    :local MessageText "\F0\9F\9F\A2 <b>$DeviceName: New DHCP client</b> %0D%0A <b>Name:</b> $"lease-hostname" %0D%0A <b>Comment:</b> [$Comment] %0D%0A <b>Interface:</b> $leaseServerName %0D%0A <b>IP:</b> $leaseActIP %0D%0A <b>MAC:</b> $leaseActMAC";
    :local SendTelegramMessage [:parse [/system script  get MyTGBotSendMessage source]]; 
    $SendTelegramMessage MessageText=$MessageText;
    #END Send Telegram Module

    # START Send Email Module
    :local SendTo "notify@mhelp.pro";
    :local Subject "\F0\9F\9F\A2 INFO: $DeviceName [$Date $Time] New DHCP client";
    :local MessageText "Name: $"lease-hostname", Comment: $Comment, Interface: $leaseServerName IP: $leaseActIP MAC: $leaseActMAC";
    :local FileName "";
    :local SendEmail [:parse [/system script get SendEmailFunction source]];
    $SendEmail SendTo=$SendTo TextMail=$MessageText Subject=$Subject FileName=$FileName;
    # END Send Email Module
}
MikroTik-scripts: Melding van apparaat verbinding met het netwerk

🟢 Dit artikel besprak het maken van een MikroTik-script om berichten van de DHCP-server te verzenden – een nieuw apparaat is verbonden met het netwerk. Ik hoop dat het je is gelukt om het verzenden van meldingen naar Telegram of e-mail in te stellen. Als u echter problemen ondervindt bij het verkrijgen van informatie, aarzel dan niet om in de opmerkingen te schrijven. Ik zal proberen te helpen.

Het script wordt gecontroleerd: hAP ac lite [RouterBOARD 952Ui-5ac2nD], RouterOS 6.47.8 (stabiel).

P.S.Als je een interessant of ongebruikelijk gebruik van het script hebt, schrijf dan in de comments, ik zal het aan het artikel toevoegen. 🙂

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *

Adblock
detector