Scripts de MikroTik: actualización automática del firmware de RouterBOARD

Script para actualizar automáticamente el firmware (cargador de arranque) de MikroTik después de actualizar la versión de RouterOS para que las versiones de MikroTik RouterOS y el cargador de arranque RouterBOARD coincidan.

Anteriormente, tenía que actualizar manualmente la versión del gestor de arranque de RouterBOARD, después de actualizar la versión de RouterOS, esto requería tiempo y atención adicionales cuando había muchos dispositivos MikroTik. Escribí un script para automatizar este proceso.

Otros idiomas:

Descripción

El script se ejecuta 2 minutos más tarde (180 segundos de retraso) después de iniciar el dispositivo MikroTik. Se comparan la versión de firmware de RouterBOARD utilizada (current-firmware) y la versión de RouterBOARD ofrecida para actualización (upgrade-firmware). Si las versiones no coinciden, el dispositivo MikroTik descarga la versión actualizada del firmware RouterBOARD y reinicia el dispositivo después de instalar la nueva versión del firmware.

✏️ Nota: Asegúrese de que después del tiempo de pausa especificado antes de ejecutar el script, la conexión a Internet se establezca realmente o aumente la demora antes de ejecutar el script.

Crear script (manualmente)

Esta secuencia de comandos debe ejecutarse tan pronto como se inicie el dispositivo, por lo que creamos la secuencia de comandos en el programador de tareas, no en el almacén de secuencias de comandos.

Menú

[System] - [Scheduler] - [+]

Datos del script

Name: AutoUpgradeFirmware
Start Time: startup
Policy: read, policy, reboot, write.

Script

:delay 180s;
/system/routerboard
:if ([get current-firmware] != [get upgrade-firmware]) do={
    upgrade;
    /system/reboot;
    }
Script de actualización automática del firmware de MikroTik RouterBOARD

Crear script (automáticamente)

/system scheduler
add name=AutoUpgradeFirmware on-event=":delay 180s;\r\
    \n/system/routerboard\r\
    \n:if ([get current-firmware] != [get upgrade-firmware]) do={\r\
    \n    upgrade;\r\
    \n    /system/reboot;\r\
    \n    }" policy=reboot,read,write,policy start-time=startup

Ahora, la versión de firmware del dispositivo (cargador de arranque) siempre es la misma que la versión de RouterOS, y no tengo que perder tiempo actualizando manualmente el firmware.

El script ha sido probado: RouterOS v7


🟢 En este artículo se analizó el script para actualización automática del firmware de RouterBOARD cuando se cambia la versión de RouterOS instalada. Espero que ahora pueda automatizar la tarea de actualizar RouterOS y la versión del gestor de arranque del dispositivo. Sin embargo, si encuentra algún problema al configurar el script, no dude en escribir en los comentarios. Trataré de ayudar.

Deja una respuesta

Tu dirección de correo electrónico no será publicada.

Adblock
detector