MikroTik-scripts: automatische upgrade van RouterBOARD-firmware

Script om automatisch de firmware (bootloader) van MikroTik te upgraden na het updaten van de versie van RouterOS, zodat deze overeenkomt met de versie van MikroTik RouterOS en de RouterBOARD-bootloader.

Voorheen moest ik de RouterBOARD bootloader-versie handmatig upgraden, na het updaten van de RouterOS-versie vergde dit extra tijd en aandacht toen er veel MikroTik-apparaten waren. Ik heb een script geschreven om dit proces te automatiseren.

Andere talen:

Beschrijving

Het script wordt 2 minuten later uitgevoerd (180 seconden vertraging) na het opstarten van het MikroTik-apparaat. De gebruikte RouterBOARD-firmwareversie (current-firmware) en de RouterBOARD-versie die voor upgrade wordt aangeboden (upgrade-firmware) worden vergeleken. Als de versies niet overeenkomen, downloadt het MikroTik-apparaat de bijgewerkte versie van de RouterBOARD-firmware en start het apparaat opnieuw op nadat de nieuwe firmwareversie is geïnstalleerd.

✏️ Opmerking: controleer of na de opgegeven pauzetijd voordat het script start, het internet echt tijd heeft om verbinding te maken of vergroot de vertraging voordat het script wordt uitgevoerd.

Script maken (handmatig)

Dit script zou moeten worden uitgevoerd zodra het apparaat opstart, dus we maken het script in de taakplanner, niet in het scriptarchief.

Menu

[System] - [Scheduler] - [+]

Script Gegevens

Name: AutoUpgradeFirmware
Start Time: startup
Policy: read, policy, reboot, write

Script

:delay 180s;
/system/routerboard
:if ([get current-firmware] != [get upgrade-firmware]) do={
    upgrade;
    /system/reboot;
    }
MikroTik RouterBOARD firmware auto upgrade script

Script maken (automatisch)

/system scheduler
add name=AutoUpgradeFirmware on-event=":delay 180s;\r\
    \n/system/routerboard\r\
    \n:if ([get current-firmware] != [get upgrade-firmware]) do={\r\
    \n    upgrade;\r\
    \n    /system/reboot;\r\
    \n    }" policy=reboot,read,write,policy start-time=startup

Nu is de firmware versie van het apparaat (bootloader) altijd hetzelfde als de RouterOS-versie en hoef ik geen tijd te besteden aan het handmatig updaten van de firmware.

Script getest: RouterOS v7


🟢 Het script voor het automatisch updaten van de firmware van een MikroTik-apparaat wanneer de geïnstalleerde RouterOS-versie wordt gewijzigd, werd in dit artikel besproken. Ik hoop dat je nu de taak van het upgraden van RouterOS en de bootloader-versie van het apparaat kunt automatiseren. Als u echter problemen ondervindt bij het instellen van het script, kunt u dit in de opmerkingen schrijven. Ik zal proberen te helpen.

Geef een antwoord

Het e-mailadres wordt niet gepubliceerd.

Adblock
detector