MikroTik Firewall: Advertenties op websites blokkeren

Blokkeren advertenties op internet met behulp van de mogelijkheden van MikroTik-apparaten. Het blokkeren gebeurt met behulp van een adreslijst (met een lijst met advertentienetwerken) en firewallregels.

We blokkeren de weergave van advertenties van grote advertentienetwerken, maar u kunt ook uw eigen advertentienetwerken toevoegen (die worden gebruikt op de sites die u bezoekt).

Onthoud dat het weergeven van advertenties een manier is om auteurs van sites te belonen (bijv. MHelp.pro).

Het blokkeren van advertentienetwerken kan ook problemen veroorzaken bij het inloggen op advertentieaccounts op websites. Overweeg dit als u of uw gebruikers webmasters zijn.

Inhoud

  1. Maak een adreslijst
  2. Maak een Firewall regel
  3. Voeg een advertentie netwerkadres toe aan de blokkeerlijst
  4. Hoe u advertentienetwerken op de site kunt vinden
  5. Lijst met populaire advertentienetwerken

Artikel in andere talen:
🇺🇸 – MikroTik Firewall: Block ads on websites
🇪🇸 – MikroTik Firewall: Bloquear anuncios los sitios web
🇷🇺 – MikroTik Firewall: Блокировка рекламы на сайтах
🇫🇷 – MikroTik Firewall: Bloquer les publicités sur les sites Web
🇩🇪 – MikroTik Firewall: Blockieren Sie Anzeigen auf Websites

Maak een adreslijst

Laten we een AdNetworks -adreslijst maken en er advertentienetwerk domeinen aan toevoegen.

[IP] -> [Firewall] -> [Address Lists] ->[+] -> [Name: AdNetworks ] -> [Comment: Blocking IP addresses of ad networks from this list.]

Terminal gebruiken:

/ip firewall address-list add list="AdNetworks" comment="Blocking IP addresses of ad networks from this list."
MikroTik Firewall: Advertenties op websites blokkeren. Maak een lijst met advertentienetwerken die u wilt blokkeren

Maak een Firewall regel

We creëren een firewallregel die, bij het detecteren van verkeer van advertentienetwerken (AdNetworks-lijst), het IP-adres van het advertentienetwerk in de blokkeerlijst plaatst – BlackList (uit het artikel “MikroTik Protection (basisinstelling apparaatbeveiliging)“).

[IP] -> [Firewall] -> [Raw] -> [+] -> [General: Chain=prerouting; Advanced: Src. Address List=AdNetworks; Action: add src to address list=BlackList, Timeout=2d 00:00:00; Comment="Rule #25 \"AdNetworksList\": drop connections from ad networks."]

Terminal gebruiken:

/ip firewall raw add chain=prerouting src-address-list=AdNetworks action=add-src-to-address-list address-list=BlackList address-list-timeout=2d comment="Rule #25 \"AdNetworksList\": drop connections from ad networks."

Plaats de regel in de Raw-tabel volgens het nummer in de opmerking.

Firewall MikroTik-regel om IP-adressen uit de lijst met advertentienetwerken te blokkeren

Voeg een advertentie netwerkadres toe aan de blokkeerlijst

Google is de meest populaire adverteerder. Blokkeer de volgende domeinen van het advertentienetwerk:

  • adservice.google.com;
  • tpc.googlesyndication.com.

Voeg het domein toe aan de adreslijst van AdNetworks:

[IP] -> [Firewall] -> [Address Lists] ->[+] -> [Name: AdNetworks; Address: adservice.google.com] -> [Comment: * Google ads]
Advertentienetwerk Domeinnamen toevoegen aan de blokkeerlijst

Voeg op dezelfde manier andere domeinnamen toe of voer het uit in de terminal:

/ip firewall address-list add address=tpc.googlesyndication.com list=AdNetworks comment="* Google ads"

U kunt ook de Google Tag Manager-service blokkeren, die wordt gebruikt om scripts van derden aan een webpagina toe te voegen:

/ip firewall address-list add address=securepubads.g.doubleclick.net list=AdNetworks comment="* Google Tag Manager"

Als u Russisch-talige sites gebruikt, voegt u de lokale advertentienetwerken Yandex en Relap toe aan de blokkeerlijst:

/ip firewall address-list add address=an.yandex.ru list=AdNetworks comment="* Yandex ads"
/ip firewall address-list add address=relap.io list=AdNetworks comment="* Relap.io ads"

Voor andere landen kunt u aan de blokkeerlijst het Criteo-advertentienetwerk toevoegen:

/ip firewall address-list add address=static.criteo.net list=AdNetworks comment="* Criteo ads"

Ik gebruik het * -teken in elke opmerking om waarden te filteren en gemakkelijk de lijst met geblokkeerde netwerken te bekijken.

Lijst met geblokkeerde advertentienetwerken weergeven

Hoe u advertentienetwerken op de site kunt vinden

Instructies voor Google Chrome:

  1. Open de pagina van de site met advertenties;
  2. Open Hulpprogramma’s voor ontwikkelaars (F12-toets of Ctrl+Shift+I combinatie);
  3. Schakel de weergave van Coverage in het paneel in;
Hoe u advertentienetwerken op de site kunt vinden. Google Chrome maakt Hulpprogramma's voor ontwikkelaars mogelijk
  1. Klik op de knop Start instrumenting coverage and reload page;
Google Chrome maakt Coverage mogelijk in Hulpprogramma's voor ontwikkelaars
  1. Filter op JavaScript en sorteer op URL.
Google Chrome geeft scripts voor advertentienetwerken weer op de site

Nu kunt u alle scripts zien die op deze webpagina worden gebruikt en scripts van ongewenste domeinnamen toevoegen aan de AdNetworks-lijst.

Ik raad niet aan om een groot aantal advertentienetwerken aan de blokkeringslijst toe te voegen – dit kan de CPU-belasting op zwakke routers aanzienlijk verhogen. Maar door grote advertentienetwerken te blokkeren, kan het aantal advertentieblokken dat wordt weergegeven voor alle apparaten in uw netwerk (vooral mobiele apparaten) aanzienlijk worden verminderd.

Grote advertentienetwerken (Google, Yandex) gebruiken advertentiemoderatie en stellen regels in die de positie of het aantal advertentieblokken op een pagina beperken. Het blokkeren van de meer “ongewenste” advertentienetwerken is waarschijnlijk de beste oplossing.

Advertenties zijn een manier van inkomen voor webmasters en motiveren hen om hoogwaardige inhoud te maken.

Lijst met veelgebruikte advertentienetwerken (wordt bijgewerkt)

Wereldwijde advertentienetwerken

Google, Criteo, Adsafeprotected.

/ip firewall address-list add address=tpc.googlesyndication.com list=AdNetworks comment="* Google ads"
/ip firewall address-list add address=adservice.google.com list=AdNetworks comment="* Google ads"
/ip firewall address-list add address=static.criteo.net list=AdNetworks comment="* Criteo ads"
/ip firewall address-list add address=static.adsafeprotected.com list=AdNetworks comment="* Adsafeprotected ads"
/ip firewall address-list add address=cdn.adsafeprotected.com list=AdNetworks comment="* Adsafeprotected ads"

Advertentienetwerken in de Russische taal

Yandex, Relap.

/ip firewall address-list add address=an.yandex.ru list=AdNetworks comment="* Yandex ads"
/ip firewall address-list add address=relap.io list=AdNetworks comment="* Relap.io ads"

Als u populaire advertentienetwerken (wereldwijd of regionaal) vindt, schrijf dan in de opmerkingen, ik zal de regels aan het artikel toevoegen.


Naast advertenties worden in het volgende artikel analysesystemen geïnstalleerd op sites die uw privacy schenden en gegevens verzamelen, over het blokkeren van analysesystemen en het vergroten van de privacy op internet.

🟢 In dit artikel werd besproken hoe u advertenties op websites kunt blokkeren met MikroTik-apparatuur. Ik hoop dat u nu het aantal weergegeven advertenties voor apparaten in uw netwerk kunt verminderen. Als u echter problemen ondervindt tijdens het instellen, kunt u in de opmerkingen schrijven. Ik zal proberen te helpen.

Geef een antwoord

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *

Adblock
detector