MikroTik Firewall: Bloquear anuncios los sitios web

Bloquear anuncios en Internet utilizando las capacidades de los dispositivos MikroTik. El bloqueo se lleva a cabo mediante una lista de direcciones (con una lista de redes publicitarias) y reglas de firewall.

Bloquear la visualización de anuncios de las principales redes publicitarias, pero también puede agregar sus propias redes publicitarias (que se utilizan en los sitios que visita).

Recuerde que mostrar anuncios es una forma de recompensar a los autores del sitio (por ejemplo, MHelp.pro).

El bloqueo de redes publicitarias también puede causar problemas al iniciar sesión en cuentas publicitarias en sitios web. Considere esto si usted o sus usuarios son webmasters.

Contenido

  1. Crear lista de direcciones
  2. Crear regla de firewall
  3. Agregar la dirección de la red publicitaria a la lista de bloqueo
  4. Cómo encontrar redes publicitarias en el sitio
  5. Lista de redes publicitarias populares

Artículo en otros idiomas:
🇺🇸 – MikroTik Firewall: Block ads on websites
🇷🇺 – MikroTik Firewall: Блокировка рекламы на сайтах
🇫🇷 – MikroTik Firewall: Bloquer les publicités sur les sites Web
🇩🇪 – MikroTik Firewall: Blockieren Sie Anzeigen auf Websites
🇳🇱 – MikroTik Firewall: Advertenties op websites blokkeren

Crear lista de direcciones

Creemos una lista de direcciones de AdNetworks y agreguemos dominios de redes publicitarias.

[IP] -> [Firewall] -> [Address Lists] ->[+] -> [Name: AdNetworks ] -> [Comment: Blocking IP addresses of ad networks from this list.]

Usando terminal:

/ip firewall address-list add list="AdNetworks" comment="Blocking IP addresses of ad networks from this list."
MikroTik bloquear anuncios los sitios web. Cree una lista de redes publicitarias para bloquear

Crear regla de firewall

Cree una regla de firewall que, al detectar el tráfico de las redes publicitarias (lista AdNetworks), coloque la dirección IP de la red publicitaria en la lista negra – BlackList (del artículo «Protección MikroTik (configuración básica de seguridad del dispositivo)«).

[IP] -> [Firewall] -> [Raw] -> [+] -> [General: Chain=prerouting; Advanced: Src. Address List=AdNetworks; Action: add src to address list=BlackList, Timeout=2d 00:00:00; Comment="Rule #25 \"AdNetworksList\": drop connections from ad networks."]

Usando terminal:

/ip firewall raw add chain=prerouting src-address-list=AdNetworks  action=add-src-to-address-list address-list=BlackList address-list-timeout=2d comment="Rule #25 \"AdNetworksList\": drop connections from ad networks."

Coloque la regla en la tabla Raw según su número en el comentario.

Regla de firewall MikroTik para bloquear direcciones IP de la lista de redes publicitarias

Agregar la dirección de la red publicitaria a la lista de bloqueo

Google es el anunciante más popular. Si no desea ver estos anuncios, bloquee los siguientes dominios de la red publicitaria:

  • adservice.google.com;
  • tpc.googlesyndication.com.

Agregue el dominio a la lista de direcciones de redes publicitarias:

[IP] -> [Firewall] -> [Address Lists] ->[+] -> [Name: AdNetworks; Address: adservice.google.com] -> [Comment: * Google ads]
Agregar nombres de dominio de redes publicitarias a la lista de bloqueo

Agregue otros nombres de dominio de la misma manera o ejecute en la terminal:

/ip firewall address-list add address=tpc.googlesyndication.com list=AdNetworks comment="* Google ads"

También puede bloquear el servicio Google Tag Manager, que se utiliza para agregar scripts de terceros a una página web:

/ip firewall address-list add address=securepubads.g.doubleclick.net list=AdNetworks comment="* Google Tag Manager"

Si usa sitios en ruso, agregue las redes publicitarias locales Yandex y Relap a la lista de bloqueo:

/ip firewall address-list add address=an.yandex.ru list=AdNetworks comment="* Yandex ads"
/ip firewall address-list add address=relap.io list=AdNetworks comment="* Relap.io ads"

Para otros países, puede agregar a la lista de bloqueo, la red publicitaria de Criteo:

/ip firewall address-list add address=static.criteo.net list=AdNetworks comment="* Criteo ads"

Utilizo el carácter * en cada comentario para filtrar valores y ver fácilmente la lista de redes bloqueadas.

Mostrar lista de redes publicitarias bloqueadas

Cómo encontrar redes publicitarias en el sitio

Instrucciones para Google Chrome:

  1. Abra la página del sitio con publicidad;
  2. Abra Herramientas para desarrolladores (tecla F12 o combinación de Ctrl+Shift+I);
  3. Encienda la visualización de Coverage en el panel;
Cómo encontrar redes publicitarias en el sitio. Google Chrome habilitar herramientas para desarrolladores
  1. Haga clic en el botón «Start instrumenting coverage and reload page«;
Google Chrome habilita la  Coverage en las herramientas para desarrolladores
  1. Filtrar por Javascript y ordenar por URL.
Google Chrome muestra scripts de redes publicitarias en el sitio.

Ahora puede ver todos los scripts utilizados en esta página web y agregar scripts de nombres de dominio no deseados a la lista de AdNetworks.

No recomiendo agregar una gran cantidad de redes publicitarias a la lista de bloqueo; esto puede aumentar significativamente la carga de la CPU en enrutadores débiles. Pero el bloqueo de las principales redes publicitarias puede reducir significativamente la cantidad de bloques de anuncios que se muestran para todos los dispositivos de su red (especialmente los móviles).

Las grandes redes publicitarias (Google, Yandex) utilizan la moderación de anuncios y establecen reglas que limitan la posición o el número de bloques de anuncios en una página. Bloquear las redes publicitarias más «basura» es probablemente la mejor solución.

Los anuncios son una forma de ingresos para los webmasters, motivándolos a crear contenido de calidad.

Lista de redes publicitarias comunes (se actualizará)

Redes publicitarias mundiales

Google, Criteo, Adsafeprotected.

/ip firewall address-list add address=tpc.googlesyndication.com list=AdNetworks comment="* Google ads"
/ip firewall address-list add address=adservice.google.com list=AdNetworks comment="* Google ads"
/ip firewall address-list add address=static.criteo.net list=AdNetworks comment="* Criteo ads"
/ip firewall address-list add address=static.adsafeprotected.com list=AdNetworks comment="* Adsafeprotected ads"
/ip firewall address-list add address=cdn.adsafeprotected.com list=AdNetworks comment="* Adsafeprotected ads"

Redes publicitarias en ruso

Yandex, Relap.

/ip firewall address-list add address=an.yandex.ru list=AdNetworks comment="* Yandex ads"
/ip firewall address-list add address=relap.io list=AdNetworks comment="* Relap.io ads"

Si encuentra redes publicitarias populares (globales o regionales), escriba en los comentarios, agregaré las reglas al artículo.


Además de los anuncios, los sistemas de análisis se instalan en sitios que violan su privacidad y recopilan datos, sobre cómo bloquear los sistemas de análisis y aumentar la privacidad en Internet, se verá en el próximo artículo.

🟢 En este artículo se discutió cómo bloquear anuncios en sitios web usando equipos MikroTik. Espero que ahora pueda reducir la cantidad de anuncios mostrados para dispositivos en su red. Sin embargo, si tiene algún problema durante la configuración, no dude en escribir en los comentarios. Trataré de ayudar.

📒 Al copiar materiales del sitio, debe indicar el autor (Yun Sergey) y un hipervínculo a la fuente (MHelp.pro).

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *