MikroTik Firewall: Bloquer les publicités sur les sites Web

Bloquer les publicités sur Internet en utilisant les capacités des appareils MikroTik. Le blocage est effectué à l’aide d’une liste d’adresses (avec une liste de réseaux publicitaires) et de règles de Firewall.

Nous bloquons l’affichage des publicités des principaux réseaux publicitaires, mais vous pouvez également ajouter vos propres réseaux publicitaires (qui sont utilisés sur les sites que vous visitez).

N’oubliez pas que l’affichage de publicités est un moyen de récompenser les auteurs de sites (par exemple MHelp.pro).

Le blocage des réseaux publicitaires peut également entraîner des problèmes de connexion à des comptes publicitaires sur des sites Web. Considérez ceci si vous ou vos utilisateurs êtes des webmasters.

Contenu

  1. Créer une liste d’adresses
  2. Créer une règle de Firewall
  3. Ajouter une adresse de réseau publicitaire à la liste de blocage
  4. Comment trouver des réseaux publicitaires sur le site
  5. Liste des réseaux publicitaires populaires

Article dans d’autres langues:
🇺🇸 – MikroTik Firewall: Block ads on websites
🇪🇸 – MikroTik Firewall: Bloquear anuncios los sitios web
🇷🇺 – MikroTik Firewall: Блокировка рекламы на сайтах
🇩🇪 – MikroTik Firewall: Blockieren Sie Anzeigen auf Websites
🇳🇱 – MikroTik Firewall: Advertenties op websites blokkeren

Créer une liste d’adresses

Let’s create an AdNetworks address list and add ad network domains to it.

[IP] -> [Firewall] -> [Address Lists] ->[+] -> [Name: AdNetworks ] -> [Comment: Blocking IP addresses of ad networks from this list.]

Utilisation du terminal:

/ip firewall address-list add list="AdNetworks" comment="Blocking IP addresses of ad networks from this list."
MikroTik bloquer les publicités sur les sites Web. Créez une liste de réseaux publicitaires à bloquer

Créer une règle de Firewall

Nous créons une règle de pare-feu qui, lors de la détection du trafic des réseaux publicitaires (liste AdNetworks), met l’adresse IP du réseau publicitaire dans la liste de blocage – BlackList (de l’article « MikroTik Protection (paramètre de sécurité de base de l’appareil)« ).

[IP] -> [Firewall] -> [Raw] -> [+] -> [General: Chain=prerouting; Advanced: Src. Address List=AdNetworks; Action: add src to address list=BlackList, Timeout=2d 00:00:00; Comment="Rule #25 \"AdNetworksList\": drop connections from ad networks."]

Utiliser le terminal:

/ip firewall raw add chain=prerouting src-address-list=AdNetworks  action=add-src-to-address-list address-list=BlackList address-list-timeout=2d comment="Rule #25 \"AdNetworksList\": drop connections from ad networks."

Placez la règle dans la table Raw en fonction de son numéro dans le commentaire.

Règle de Firewall MikroTik pour bloquer les adresses IP de la liste des réseaux publicitaires

Ajouter une adresse de réseau publicitaire à la liste de blocage

Google est l’annonceur le plus populaire. Si vous ne souhaitez pas voir ces annonces, veuillez bloquer les domaines suivants du réseau publicitaire:

  • adservice.google.com;
  • tpc.googlesyndication.com.

Ajouter le domaine à la liste d’adresses AdNetworks:

[IP] -> [Firewall] -> [Address Lists] ->[+] -> [Name: AdNetworks; Address: adservice.google.com] -> [Comment: * Google ads]
Ajout de noms de domaine de réseau publicitaire à la liste de blocage

Ajoutez d’autres noms de domaine de la même manière ou exécutez dans le terminal:

/ip firewall address-list add address=tpc.googlesyndication.com list=AdNetworks comment="* Google ads"

Vous pouvez également bloquer le service Google Tag Manager, qui est utilisé pour ajouter des scripts tiers à une page Web:

/ip firewall address-list add address=securepubads.g.doubleclick.net list=AdNetworks comment="* Google Tag Manager"

Si vous utilisez des sites en russe, ajoutez les réseaux publicitaires locaux Yandex et Relap à la liste de blocage:

/ip firewall address-list add address=an.yandex.ru list=AdNetworks comment="* Yandex ads"
/ip firewall address-list add address=relap.io list=AdNetworks comment="* Relap.io ads"

Pour les autres pays, vous pouvez ajouter à la liste de blocage, le réseau publicitaire Criteo:

/ip firewall address-list add address=static.criteo.net list=AdNetworks comment="* Criteo ads"

J’utilise le caractère * dans chaque commentaire pour filtrer les valeurs et afficher facilement la liste des réseaux bloqués.

Afficher la liste des réseaux publicitaires bloqués

Comment trouver des réseaux publicitaires sur le site

Instructions pour Google Chrome:

  1. Ouvrez la page du site avec de la publicité;
  2. Ouvrez les Outils de développement (touche F12 ou combinaison Ctrl+Maj+I);
  3. Activez l’affichage de la Coverage dans le panneau;
Comment trouver des réseaux publicitaires sur le site. Google Chrome activant les outils de développement
  1. Cliquez sur le bouton Start instrumenting coverage and reload page;
Google Chrome activant la couverture dans les outils de développement
  1. Filtrer par Javascript et trier par URL.
Google Chrome affichant des scripts de régie publicitaire sur le site

Vous pouvez désormais voir tous les scripts utilisés sur cette page Web et ajouter des scripts de noms de domaine indésirables à la liste AdNetworks.

Je ne recommande pas d’ajouter un grand nombre de réseaux publicitaires à la liste de blocage – cela peut augmenter considérablement la charge du processeur sur les routeurs faibles. Mais le blocage des principaux réseaux publicitaires peut réduire considérablement le nombre de blocs d’annonces affichés pour tous les appareils de votre réseau (en particulier les mobiles).

Les grands réseaux publicitaires (Google, Yandex) utilisent la modération des annonces et définissent des règles qui limitent la position ou le nombre de blocs d’annonces sur une page. Bloquer les réseaux publicitaires les plus «indésirables» est probablement la meilleure solution.

Les publicités sont une source de revenus pour les webmasters, les incitant à créer un contenu de qualité.

Liste des réseaux publicitaires courants (sera mise à jour)

Réseaux publicitaires mondiaux

Google, Criteo, Adsafeprotected.

/ip firewall address-list add address=tpc.googlesyndication.com list=AdNetworks comment="* Google ads"
/ip firewall address-list add address=adservice.google.com list=AdNetworks comment="* Google ads"
/ip firewall address-list add address=static.criteo.net list=AdNetworks comment="* Criteo ads"
/ip firewall address-list add address=static.adsafeprotected.com list=AdNetworks comment="* Adsafeprotected ads"
/ip firewall address-list add address=cdn.adsafeprotected.com list=AdNetworks comment="* Adsafeprotected ads"

Réseaux publicitaires en russe

Yandex, Relap.

/ip firewall address-list add address=an.yandex.ru list=AdNetworks comment="* Yandex ads"
/ip firewall address-list add address=relap.io list=AdNetworks comment="* Relap.io ads"

Si vous trouvez des réseaux publicitaires populaires (mondiaux ou régionaux), écrivez dans les commentaires, j’ajouterai les règles à l’article.


En plus des publicités, des systèmes d’analyse sont installés sur des sites qui violent votre vie privée et collectent des données, sur le blocage des systèmes d’analyse et l’augmentation de la confidentialité sur Internet, seront dans le prochain article.

🟢 Comment bloquer les publicités sur les sites Web utilisant l’équipement MikroTik a été abordé dans cet article. J’espère que vous pouvez désormais réduire le nombre d’annonces affichées pour les appareils de votre réseau. Cependant, si vous rencontrez des problèmes lors de la configuration, n’hésitez pas à écrire dans les commentaires. J’essaierai d’aider.

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Adblock
detector